diff mbox series

[bug#65043] gnu: python-graph-tool: Update to 2.57.

Message ID 20230803180002.22937-1-code@greghogan.com
State New
Headers show
Series [bug#65043] gnu: python-graph-tool: Update to 2.57. | expand

Commit Message

Greg Hogan Aug. 3, 2023, 5:59 p.m. UTC
* gnu/packages/graph.scm (python-graph-tool): Update to 2.57.
[propagated-inputs]: Add python-zstandard.
---
 gnu/packages/graph.scm | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

Comments

Christopher Baines Aug. 27, 2023, 6:51 p.m. UTC | #1
Greg Hogan <code@greghogan.com> writes:

> * gnu/packages/graph.scm (python-graph-tool): Update to 2.57.
> [propagated-inputs]: Add python-zstandard.
> ---
>  gnu/packages/graph.scm | 11 ++++++++---
>  1 file changed, 8 insertions(+), 3 deletions(-)

Thanks, I've pushed this to master as
6482f61a0cf65bd32be0a9bbd0ce5c349b28c0c0.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index c5e7410b2a..881033047d 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -57,6 +57,7 @@  (define-module (gnu packages graph)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
+  #:use-module (gnu packages python-compression)
   #:use-module (gnu packages python-science)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
@@ -630,7 +631,7 @@  (define-public mscgen
 (define-public python-graph-tool
   (package
     (name "python-graph-tool")
-    (version "2.46")
+    (version "2.57")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -638,7 +639,7 @@  (define-public python-graph-tool
                     version ".tar.bz2"))
               (sha256
                (base32
-                "0x9jgnq9xcja3q954y7nhdzd374p4h203pymxh51b6lqqbq0hm9h"))))
+                "0wmvzx509lvigja6cfxh45r4b7wns64vmik0x4rz4y4fnxrhw2m2"))))
     (build-system gnu-build-system)
     (arguments
      `(#:imported-modules (,@%gnu-build-system-modules
@@ -662,7 +663,11 @@  (define-public python-graph-tool
            python-wrapper
            sparsehash))
     (propagated-inputs
-     (list python-matplotlib python-numpy python-pycairo python-scipy))
+     (list python-matplotlib
+           python-numpy
+           python-pycairo
+           python-scipy
+           python-zstandard))
     (synopsis "Manipulate and analyze graphs with Python efficiently")
     (description "Graph-tool is an efficient Python module for manipulation
 and statistical analysis of graphs (a.k.a. networks).  Contrary to most other