diff mbox series

[bug#65028] gnu: loksh: Update to 7.3.

Message ID 20230802211816.3932-1-soeren@soeren-tempel.net
State New
Headers show
Series [bug#65028] gnu: loksh: Update to 7.3. | expand

Commit Message

Sören Tempel Aug. 2, 2023, 9:17 p.m. UTC
From: Sören Tempel <soeren@soeren-tempel.net>

* gnu/packages/shells.scm (loksh): Update to 7.3.
  [source]: Update style.

Signed-off-by: Sören Tempel <soeren@soeren-tempel.net>
---
I did both the upgrade and the reformatting with guix style (as
instructed in the Guix manual) in one commit. Hope that is ok.

 gnu/packages/shells.scm | 34 ++++++++++++++++------------------
 1 file changed, 16 insertions(+), 18 deletions(-)

Comments

Ludovic Courtès Aug. 12, 2023, 9:17 p.m. UTC | #1
Hi,

soeren@soeren-tempel.net skribis:

> From: Sören Tempel <soeren@soeren-tempel.net>
>
> * gnu/packages/shells.scm (loksh): Update to 7.3.
>   [source]: Update style.
>
> Signed-off-by: Sören Tempel <soeren@soeren-tempel.net>
> ---
> I did both the upgrade and the reformatting with guix style (as
> instructed in the Guix manual) in one commit. Hope that is ok.

Perfect.  Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index aef22efd01..e9d0fffec1 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -788,26 +788,24 @@  (define-public oksh
 (define-public loksh
   (package
     (name "loksh")
-    (version "6.9")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/dimkr/loksh")
-             (commit version)
-             ;; Include the ‘lolibc’ submodule, a static compatibility library
-             ;; created for and currently used only by loksh.
-             (recursive? #t)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0x33plxqhh5202hgqidgccz5hpg8d2q71ylgnm437g60mfi9z0px"))))
+    (version "7.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dimkr/loksh")
+                    (commit version)
+                    ;; Include the ‘lolibc’ submodule, a static compatibility library
+                    ;; created for and currently used only by loksh.
+                    (recursive? #t)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1miydvb79wagckchinp189l8i81f08lqajg5jngn77m4x4gwjf3n"))))
     (build-system meson-build-system)
-    (inputs
-     (list ncurses))
-    (native-inputs
-     (list pkg-config))
+    (inputs (list ncurses))
+    (native-inputs (list pkg-config))
     (arguments
-     `(#:tests? #f))                    ; no tests included
+     `(#:tests? #f)) ;no tests included
     (home-page "https://github.com/dimkr/loksh")
     (synopsis "Korn Shell from OpenBSD")
     (description