diff mbox series

[bug#55751,v2,7/7] gnu: openjdk15: Make reproducible.

Message ID 20230731180919.28047-8-dannym@scratchpost.org
State New
Headers show
Series Towards reproducible openjdk | expand

Commit Message

Danny Milosavljevic July 31, 2023, 6:09 p.m. UTC
* gnu/packages/java.scm (openjdk15)[source]: Add patch.
---
 gnu/packages/java.scm                         |  3 +-
 .../openjdk-15-jtask-reproducibility.patch    | 40 +++++++++++++++++++
 2 files changed, 42 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/openjdk-15-jtask-reproducibility.patch

Comments

Maxim Cournoyer Jan. 21, 2024, 5:22 a.m. UTC | #1
Hello!

Danny Milosavljevic <dannym@scratchpost.org> writes:

> * gnu/packages/java.scm (openjdk15)[source]: Add patch.
> ---
>  gnu/packages/java.scm                         |  3 +-
>  .../openjdk-15-jtask-reproducibility.patch    | 40 +++++++++++++++++++
>  2 files changed, 42 insertions(+), 1 deletion(-)
>  create mode 100644 gnu/packages/patches/openjdk-15-jtask-reproducibility.patch

I've queued your work for core-updates.  Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d4176f1375..a8aaedb8af 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1568,7 +1568,8 @@  (define-public openjdk15
              (modules '())
              (snippet #f)
              (patches
-              (search-patches "openjdk-15-xcursor-no-dynamic.patch"))))
+              (search-patches "openjdk-15-jtask-reproducibility.patch"
+                              "openjdk-15-xcursor-no-dynamic.patch"))))
    (inputs
     (modify-inputs (package-inputs base)
       (append libxcursor)))             ;for our patch to work
diff --git a/gnu/packages/patches/openjdk-15-jtask-reproducibility.patch b/gnu/packages/patches/openjdk-15-jtask-reproducibility.patch
new file mode 100644
index 0000000000..2052983ade
--- /dev/null
+++ b/gnu/packages/patches/openjdk-15-jtask-reproducibility.patch
@@ -0,0 +1,40 @@ 
+--- 22kjr9lzrml0h5m55viq7zlfkqr9p7ny-openjdk-15.0.3-checkout/src/jdk.jlink/share/classes/jdk/tools/jmod/JmodTask.java.orig	2022-04-04 10:57:40.346312924 +0200
++++ 22kjr9lzrml0h5m55viq7zlfkqr9p7ny-openjdk-15.0.3-checkout/src/jdk.jlink/share/classes/jdk/tools/jmod/JmodTask.java	2022-04-04 11:01:38.480751902 +0200
+@@ -82,6 +82,7 @@
+ import jdk.internal.module.ModuleTarget;
+ import jdk.internal.module.Resources;
+ import jdk.tools.jlink.internal.Utils;
++import java.util.TreeSet;
+ 
+ import static java.util.stream.Collectors.joining;
+ 
+@@ -750,6 +751,7 @@
+         void processSection(JmodOutputStream out, Section section, Path path)
+             throws IOException
+         {
++            TreeSet<Path> paths = new TreeSet<>();
+             Files.walkFileTree(path, Set.of(FileVisitOption.FOLLOW_LINKS),
+                 Integer.MAX_VALUE, new SimpleFileVisitor<Path>() {
+                     @Override
+@@ -765,14 +767,18 @@
+                             if (out.contains(section, name)) {
+                                 warning("warn.ignore.duplicate.entry", name, section);
+                             } else {
+-                                try (InputStream in = Files.newInputStream(file)) {
+-                                    out.writeEntry(in, section, name);
+-                                }
++                                paths.add(file);
+                             }
+                         }
+                         return FileVisitResult.CONTINUE;
+                     }
+                 });
++
++            for (Path file : paths) {
++                try (InputStream in = Files.newInputStream(file)) {
++                    out.writeEntry(in, section, path.relativize(file).toString());
++                }
++            }
+         }
+ 
+         boolean matches(Path path, List<PathMatcher> matchers) {