diff mbox series

[bug#64748,v4] gnu: webrtc-for-telegram-desktop: Update to a45d8b8

Message ID 20230726192211.20232-1-distopico@riseup.net
State New
Headers show
Series [bug#64748,v4] gnu: webrtc-for-telegram-desktop: Update to a45d8b8 | expand

Commit Message

Distopico July 26, 2023, 7:21 p.m. UTC
Fixes telegram-desktop call not working with openSSL 3 ,
Use sources from `libsrtp` instead of the submodule.

see: https://github.com/telegramdesktop/tdesktop/issues/26108

* gnu/packages/telegram.scm (webrtc-for-telegram-desktop): Update to a45d8b8 revision commit
---
 gnu/packages/telegram.scm | 17 +++++++++++------
 1 file changed, 11 insertions(+), 6 deletions(-)

Comments

Saku Laesvuori July 26, 2023, 8:09 p.m. UTC | #1
> Fixes telegram-desktop call not working with openSSL 3 ,
> Use sources from `libsrtp` instead of the submodule.
> 
> see: https://github.com/telegramdesktop/tdesktop/issues/26108
> 
> * gnu/packages/telegram.scm (webrtc-for-telegram-desktop): Update to a45d8b8 revision commit
> ---

I wonder if this ChangeLog should mention something about adding libsrtp
sources to the unpack-additional-sources phase. Otherwise it looks good
to me and is just waiting for someone with more experience/commit
access.
diff mbox series

Patch

diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index aa01c2f692..0b32b49d14 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -265,8 +266,8 @@  (define tgcalls-for-telegram-desktop
       "193m2gkvipijqbfd6a8mhg9nd63wlnshzgspk3pip57vk21l709z"))))
 
 (define-public webrtc-for-telegram-desktop
-  (let ((commit "5098730b9eb6173f0b52068fe2555b7c1015123a")
-        (revision "328"))
+  (let ((commit "a45d8b8f0a99bd0e5118dda1dc4a8b7b3ad5dcfd")
+        (revision "388"))
     (hidden-package
      (package
        (name "webrtc-for-telegram-desktop")
@@ -282,14 +283,14 @@  (define-public webrtc-for-telegram-desktop
           (file-name
            (git-file-name name version))
           (sha256
-           (base32 "1lk54zlrff59rj5k9dylsgz4sdds4728psrk8m3v9qn5y8d6z8qy"))
+           (base32 "1qs3ikkd6l56brj40cv6wlhx5gj5avisj9mj8ypjfwcyw9hb2n5y"))
           (modules '((guix build utils)
                      (ice-9 ftw)
                      (srfi srfi-1)))
           (snippet
            #~(begin
                (let ((keep
-                      '("libsrtp" "rnnoise"
+                      '("rnnoise" "libsrtp_config"
                         ;; Not available in Guix.
                         "pffft")))
                  (with-directory-excursion "src/third_party"
@@ -311,9 +312,13 @@  (define-public webrtc-for-telegram-desktop
              (add-after 'unpack 'unpack-additional-sources
                (lambda _
                  (let* ((third-party (string-append (getcwd) "/src/third_party"))
-                        (libyuv-to (string-append third-party "/libyuv")))
+                        (libyuv-to (string-append third-party "/libyuv"))
+                        (libsrtp-to (string-append third-party "/libsrtp")))
                    (copy-recursively #$libyuv-for-telegram-desktop
-                                     libyuv-to)))))))
+                                     libyuv-to)
+                   (copy-recursively #$(package-source
+				        libsrtp)
+                                     libsrtp-to)))))))
        (native-inputs (list pkg-config python-wrapper yasm))
        (inputs
         (list abseil-cpp-cxxstd17