diff mbox series

[bug#64748,v3] gnu: webrtc-for-telegram-desktop: Update to a45d8b8

Message ID 20230726185551.1911-1-distopico@riseup.net
State New
Headers show
Series [bug#64748,v3] gnu: webrtc-for-telegram-desktop: Update to a45d8b8 | expand

Commit Message

Distopico July 26, 2023, 6:54 p.m. UTC
Fixes telegram-desktop call not working with openSSL 3 ,
Use sources from `libsrtp` instead of the submodule.

gnu: libsrtp: Update to 2.5.0.

see: https://github.com/telegramdesktop/tdesktop/issues/26108

* gnu/packages/telegram.scm (webrtc-for-telegram-desktop): Update to a45d8b8 revision commit
* gnu/packages/telephony.scm (libsrtp): Update to 2.5.0.
---
 use sources from existing `libsrtp` package,
 update it to the last version

 gnu/packages/telegram.scm  | 17 +++++++++++------
 gnu/packages/telephony.scm |  4 ++--
 2 files changed, 13 insertions(+), 8 deletions(-)

Comments

Saku Laesvuori July 26, 2023, 7:13 p.m. UTC | #1
> diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
> index aa65c4eaad..dc0adc7334 100644
> --- a/gnu/packages/telephony.scm
> +++ b/gnu/packages/telephony.scm
> @@ -456,7 +456,7 @@ (define-public sipwitch
>  (define-public libsrtp
>    (package
>      (name "libsrtp")
> -    (version "2.4.2")
> +    (version "2.5.0")

This should be split to a separate commit (one package per commit).

Also, according to `guix refresh --list-dependent libsrtp` libsrtp has
739 (>300) dependent packages and should thus not be updated on master to avoid
a drop in substitute availability. Have you checked if the calls work
with libsrtp 2.4.2 so that the telegram update could be applied to
master without updating libsrtp?
Distopico July 26, 2023, 7:22 p.m. UTC | #2
actually I tested first with 2.4.2 and it works fine from my side.

On 2023-07-26, Saku Laesvuori <saku@laesvuori.fi> wrote:

> [[PGP Signed Part:Undecided]]
>> diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
>> index aa65c4eaad..dc0adc7334 100644
>> --- a/gnu/packages/telephony.scm
>> +++ b/gnu/packages/telephony.scm
>> @@ -456,7 +456,7 @@ (define-public sipwitch
>>  (define-public libsrtp
>>    (package
>>      (name "libsrtp")
>> -    (version "2.4.2")
>> +    (version "2.5.0")
>
> This should be split to a separate commit (one package per commit).
>
> Also, according to `guix refresh --list-dependent libsrtp` libsrtp has
> 739 (>300) dependent packages and should thus not be updated on master to avoid
> a drop in substitute availability. Have you checked if the calls work
> with libsrtp 2.4.2 so that the telegram update could be applied to
> master without updating libsrtp?
>
> [[End of PGP Signed Part]]
diff mbox series

Patch

diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index aa01c2f692..0b32b49d14 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -265,8 +266,8 @@  (define tgcalls-for-telegram-desktop
       "193m2gkvipijqbfd6a8mhg9nd63wlnshzgspk3pip57vk21l709z"))))
 
 (define-public webrtc-for-telegram-desktop
-  (let ((commit "5098730b9eb6173f0b52068fe2555b7c1015123a")
-        (revision "328"))
+  (let ((commit "a45d8b8f0a99bd0e5118dda1dc4a8b7b3ad5dcfd")
+        (revision "388"))
     (hidden-package
      (package
        (name "webrtc-for-telegram-desktop")
@@ -282,14 +283,14 @@  (define-public webrtc-for-telegram-desktop
           (file-name
            (git-file-name name version))
           (sha256
-           (base32 "1lk54zlrff59rj5k9dylsgz4sdds4728psrk8m3v9qn5y8d6z8qy"))
+           (base32 "1qs3ikkd6l56brj40cv6wlhx5gj5avisj9mj8ypjfwcyw9hb2n5y"))
           (modules '((guix build utils)
                      (ice-9 ftw)
                      (srfi srfi-1)))
           (snippet
            #~(begin
                (let ((keep
-                      '("libsrtp" "rnnoise"
+                      '("rnnoise" "libsrtp_config"
                         ;; Not available in Guix.
                         "pffft")))
                  (with-directory-excursion "src/third_party"
@@ -311,9 +312,13 @@  (define-public webrtc-for-telegram-desktop
              (add-after 'unpack 'unpack-additional-sources
                (lambda _
                  (let* ((third-party (string-append (getcwd) "/src/third_party"))
-                        (libyuv-to (string-append third-party "/libyuv")))
+                        (libyuv-to (string-append third-party "/libyuv"))
+                        (libsrtp-to (string-append third-party "/libsrtp")))
                    (copy-recursively #$libyuv-for-telegram-desktop
-                                     libyuv-to)))))))
+                                     libyuv-to)
+                   (copy-recursively #$(package-source
+				        libsrtp)
+                                     libsrtp-to)))))))
        (native-inputs (list pkg-config python-wrapper yasm))
        (inputs
         (list abseil-cpp-cxxstd17
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index aa65c4eaad..dc0adc7334 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -456,7 +456,7 @@  (define-public sipwitch
 (define-public libsrtp
   (package
     (name "libsrtp")
-    (version "2.4.2")
+    (version "2.5.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -465,7 +465,7 @@  (define-public libsrtp
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1gswpjm4jacfxmgglbf8hxi3yzsag4drk4q943p0wkmv21zj8l78"))))
+                "1ichw2v9s2mggi5p2wbbmlg55q4r48dxi3ks7ykfcfkmh7pb1w1s"))))
     (native-inputs
      (list psmisc ;some tests require 'killall'
            procps))