diff mbox series

[bug#64779,core-updates] gnu: coreutils: Skip tests which are broken on btrfs

Message ID 20230722005515.32202-1-ryan@arctype.co
State New
Headers show
Series [bug#64779,core-updates] gnu: coreutils: Skip tests which are broken on btrfs | expand

Commit Message

Ryan Sundberg July 22, 2023, 12:55 a.m. UTC
When building coreutils on a BTRFS filesystem, this test case
consistently fails.

* gnu/packages/base.scm (coreutils): Skip tests/cp/reflink-auto.sh
---
 gnu/packages/base.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Maxim Cournoyer July 22, 2023, 1:55 a.m. UTC | #1
Hello,

Ryan Sundberg <ryan@arctype.co> writes:

> When building coreutils on a BTRFS filesystem, this test case
> consistently fails.
>
> * gnu/packages/base.scm (coreutils): Skip tests/cp/reflink-auto.sh
> ---
>  gnu/packages/base.scm | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
> index 1fdfaf8a57..a9dab0b30f 100644
> --- a/gnu/packages/base.scm
> +++ b/gnu/packages/base.scm
> @@ -464,7 +464,11 @@ (define-public coreutils
>                                 ;; there might be some environmental factor
>                                 ;; here
>                                 ((" test-tls\\$\\(EXEEXT\\) ") " ")))
> -                           '())
> +                           '((substitute*
> +                               ;; This test fails on BTRFS
> +                               '("tests/cp/reflink-auto.sh")
> +                               (("^#!.*" all)
> +                                (string-append all "exit 77;\n")))))

Could you please report the issue to upstream, and add a comment with a
reference to the open issue?
Maxim Cournoyer Jan. 21, 2024, 2:47 a.m. UTC | #2
tags 64779 + unreproducible
quit

Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hello,
>
> Ryan Sundberg <ryan@arctype.co> writes:
>
>> When building coreutils on a BTRFS filesystem, this test case
>> consistently fails.
>>
>> * gnu/packages/base.scm (coreutils): Skip tests/cp/reflink-auto.sh
>> ---
>>  gnu/packages/base.scm | 6 +++++-
>>  1 file changed, 5 insertions(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
>> index 1fdfaf8a57..a9dab0b30f 100644
>> --- a/gnu/packages/base.scm
>> +++ b/gnu/packages/base.scm
>> @@ -464,7 +464,11 @@ (define-public coreutils
>>                                 ;; there might be some environmental factor
>>                                 ;; here
>>                                 ((" test-tls\\$\\(EXEEXT\\) ") " ")))
>> -                           '())
>> +                           '((substitute*
>> +                               ;; This test fails on BTRFS
>> +                               '("tests/cp/reflink-auto.sh")
>> +                               (("^#!.*" all)
>> +                                (string-append all "exit 77;\n")))))
>
> Could you please report the issue to upstream, and add a comment with a
> reference to the open issue?

I've searched the upstream issue tracker, and found none about this.
I've built coreutils 9.1 and latest master from source on my Btrfs
machine, which ran the test suite fine.  I've also rebuilt the current
Guix coreutils package with success on the same machine.

I don't think the problem is with Btrfs, or at least it's not easy to
reproduce.

Closing for now.
diff mbox series

Patch

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 1fdfaf8a57..a9dab0b30f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -464,7 +464,11 @@  (define-public coreutils
                                ;; there might be some environmental factor
                                ;; here
                                ((" test-tls\\$\\(EXEEXT\\) ") " ")))
-                           '())
+                           '((substitute*
+                               ;; This test fails on BTRFS
+                               '("tests/cp/reflink-auto.sh")
+                               (("^#!.*" all)
+                                (string-append all "exit 77;\n")))))
                      (substitute* "Makefile.in"
                        ;; fails on filesystems where inotify cannot be used,
                        ;; more info in #47935