diff mbox series

[bug#64149,v4,5/5] gnu: patman: Add python-u-boot-pylib to inputs.

Message ID 20230720014459.242139-6-vagrant@debian.org
State New
Headers show
Series Update U-boot to 2023.07.02. | expand

Commit Message

Vagrant Cascadian July 20, 2023, 1:44 a.m. UTC
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>

* gnu/packages/bootloaders.scm (patman) [inputs]: Add python-u-boot-pylib.
[phases]: Remove 'sanity-check.
---
 gnu/packages/bootloaders.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 8afb2c3293..30ef673f7d 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -876,10 +876,13 @@  (define-public patman
       #:tests? #f
       #:phases
       #~(modify-phases %standard-phases
+          ;; Patman fails to run during 'sanity-check phase, as it needs to be
+          ;; run within a git directory.
+          (delete 'sanity-check)
           (add-after 'unpack 'chdir
             (lambda _
               (chdir "tools/patman"))))))
-    (inputs (list python-pygit2 python-requests))
+    (inputs (list python-pygit2 python-requests python-u-boot-pylib))
     (synopsis "Patch automation tool")
     (description "Patman is a patch automation script which:
 @itemize