diff mbox series

[bug#64720] gnu: rust-analyzer: Fix build of rust-analyzer.

Message ID 20230719022804.19613-1-distopico@riseup.net
State New
Headers show
Series [bug#64720] gnu: rust-analyzer: Fix build of rust-analyzer. | expand

Commit Message

Distopico July 19, 2023, 2:26 a.m. UTC
Fixes build of rust-analyzer version 2022-01-10 that requires pined version of
rust-notify which is `rust-notify-pre.13`.

I'm working to update `rust-analizer` to 2023-07-17 but it require add more
packages and update other, it's a WIP but for now this is just to fix the build.

* gnu/packages/crates-io.scm (rust-notify-5-pre.13): New variable.
* gnu/packages/rust-apps.scm
---
 gnu/packages/crates-io.scm | 13 +++++++++++++
 gnu/packages/rust-apps.scm |  2 +-
 2 files changed, 14 insertions(+), 1 deletion(-)


base-commit: 917a299831361f253ea664f009176b4bbe06900a

Comments

Liliana Marie Prikler July 29, 2023, 6:44 p.m. UTC | #1
Am Dienstag, dem 18.07.2023 um 21:26 -0500 schrieb Distopico:
> Fixes build of rust-analyzer version 2022-01-10 that requires pined
pinned
> version of rust-notify which is `rust-notify-pre.13`.
> 
> I'm working to update `rust-analizer` to 2023-07-17 but it require
> add more
Please stick to one spelling of rust-analyzer.  Also, comments that
shouldn't end up in the commit messages go below the "---" line.
> packages and update other, it's a WIP but for now this is just to fix
> the build.
> 
> * gnu/packages/crates-io.scm (rust-notify-5-pre.13): New variable.
> * gnu/packages/rust-apps.scm
The ChangeLog here is incomplete.  Also, I'm pretty sure this would be
a two-patch series.
> ---
>  gnu/packages/crates-io.scm | 13 +++++++++++++
>  gnu/packages/rust-apps.scm |  2 +-
>  2 files changed, 14 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index f9574e2797..5dd9e0d349 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -38927,6 +38927,19 @@ (define-public rust-notify-5
>  notification library.")
>      (license (list license:cc0 license:artistic2.0))))
>  
> +(define-public rust-notify-5-pre.13
> +  (package
> +    (inherit rust-notify-5)
> +    (name "rust-notify")
> +    (version "5.0.0-pre.13")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (crate-uri "notify" version))
> +              (file-name (string-append name "-" version ".tar.gz"))
> +              (sha256
> +               (base32
> +               
> "0za8mpacxkr62fii5h7ny4h396y0m8myd3hf08njqdg2h21kap94"))))))
> +
LGTM, but idk anything about rust.
>  (define-public rust-notify-4
>    (package
>      (inherit rust-notify-5)
> diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
> index 8c29969712..0571af498c 100644
> --- a/gnu/packages/rust-apps.scm
> +++ b/gnu/packages/rust-apps.scm
> @@ -1775,7 +1775,7 @@ (define-public rust-analyzer
>          ("rust-memmap2" ,rust-memmap2-0.5)
>          ("rust-mimalloc" ,rust-mimalloc-0.1)
>          ("rust-miow" ,rust-miow-0.4)
> -        ("rust-notify" ,rust-notify-5)
> +        ("rust-notify" ,rust-notify-5-pre.13)
>          ("rust-object" ,rust-object-0.28)
>          ("rust-once-cell" ,rust-once-cell-1)
>          ("rust-parking-lot" ,rust-parking-lot-0.11)
Same here.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f9574e2797..5dd9e0d349 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -38927,6 +38927,19 @@  (define-public rust-notify-5
 notification library.")
     (license (list license:cc0 license:artistic2.0))))
 
+(define-public rust-notify-5-pre.13
+  (package
+    (inherit rust-notify-5)
+    (name "rust-notify")
+    (version "5.0.0-pre.13")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "notify" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0za8mpacxkr62fii5h7ny4h396y0m8myd3hf08njqdg2h21kap94"))))))
+
 (define-public rust-notify-4
   (package
     (inherit rust-notify-5)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 8c29969712..0571af498c 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1775,7 +1775,7 @@  (define-public rust-analyzer
         ("rust-memmap2" ,rust-memmap2-0.5)
         ("rust-mimalloc" ,rust-mimalloc-0.1)
         ("rust-miow" ,rust-miow-0.4)
-        ("rust-notify" ,rust-notify-5)
+        ("rust-notify" ,rust-notify-5-pre.13)
         ("rust-object" ,rust-object-0.28)
         ("rust-once-cell" ,rust-once-cell-1)
         ("rust-parking-lot" ,rust-parking-lot-0.11)