diff mbox series

[bug#64149,5/5] gnu: patman: Add python-u-boot-pylib to inputs.

Message ID 20230709014736.54114-5-vagrant@debian.org
State New
Headers show
Series [bug#64149,1/5] gnu: arm-trusted-firmware: Update to 2.9. | expand

Commit Message

Vagrant Cascadian July 9, 2023, 1:47 a.m. UTC
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>

* gnu/packages/bootloaders.scm (patman) [inputs]: Add python-u-boot-pylib.
---
 gnu/packages/bootloaders.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Vagrant Cascadian July 10, 2023, 7:39 p.m. UTC | #1
On 2023-07-08, vagrant@debian.org wrote:
> From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
>
> * gnu/packages/bootloaders.scm (patman) [inputs]: Add python-u-boot-pylib.

So I did successfully build with 'sanity-check removed.

I tried creating a little git playground for patman to run the patman
self-tests with, but 'sanity-check ended up in some other directory and
still failed.

Even "patman --help" spits out this ugly traceback if it is not run from
inside a working git directory...

Soo.... maybe deleting 'sanity-check is the way to go here? Not sure
what else we would be missing...

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 827894e447..9098b2a8e2 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -878,7 +878,7 @@  (define-public patman
           (add-after 'unpack 'chdir
             (lambda _
               (chdir "tools/patman"))))))
-    (inputs (list python-pygit2 python-requests))
+    (inputs (list python-pygit2 python-requests python-u-boot-pylib))
     (synopsis "Patch automation tool")
     (description "Patman is a patch automation script which:
 @itemize