diff mbox series

[bug#64408] gnu: Add privacybrowser.

Message ID 20230701224939.5503-1-soren@stoutner.com
State New
Headers show
Series [bug#64408] gnu: Add privacybrowser. | expand

Commit Message

Soren Stoutner July 1, 2023, 10:49 p.m. UTC
* gnu/packages/privacybrowser.scm: New file.
---
 gnu/packages/privacybrowser.scm | 58 +++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)
 create mode 100644 gnu/packages/privacybrowser.scm

Comments

Soren Stoutner July 24, 2023, 4:16 p.m. UTC | #1
What is the next step to get Privacy Browser added to Guix?
Tobias Geerinckx-Rice Aug. 16, 2023, 7:08 p.m. UTC | #2
Hi Soren,

Thanks for the patch!  It looks good, but I wonder about ‘khelpcenter’.

Notably, it doesn't enable the ‘Help’ → ‘Privacy Browser Handbook’.  
That prints

   kf.guiaddons: Could not find a suitable handler for "help:/"

in the console and does nothing in the GUI.  Is this something that 
could be fixed?

If it's something that requires a full(er) KDE installation, does adding 
‘khelpcenter’ make a difference?  It doesn't for me.

Kind regards,

T G-R

Sent from a Web browser.  Excuse or enjoy my brevity.
Soren Stoutner Oct. 16, 2023, 5:44 p.m. UTC | #3
I apologize for not responding sooner.  I assumed that when someone commented 
on the issue I would receive an email, but either it never came or I missed it 
somehow.

KHelpCenter is required to be able to open the Handbook (press F1 inside of 
the program).  There is a lot of important information in the Handbook that 
users of Privacy Browser would benefit reading.
Soren Stoutner Oct. 16, 2023, 7:12 p.m. UTC | #4
Note that for KHelpCenter to function, it must be specified at runtime.  For 
example:

guix shell privacybrowser khelpcenter -- privacybrowser

It seems there are a few missing icons and there are some warnings written to 
the console.  I assume that relates to some deficiency in the KHelpCenter 
package.  But all the text of the Handbook can be read.
Clément Lassieur Jan. 13, 2024, 10:45 a.m. UTC | #5
Hi,

Thank you for this patch.

On Mon, Oct 16 2023, Soren Stoutner via Guix-patches via wrote:

> Note that for KHelpCenter to function, it must be specified at runtime.  For 
> example:
>
> guix shell privacybrowser khelpcenter -- privacybrowser

Maybe it should be a propagated input then?


Also does it have to be in a specific file?  I imagine it could fit in
qt.scm?

Thanks,
Clément
Soren Stoutner Jan. 13, 2024, 5:49 p.m. UTC | #6
Clément

On Saturday, January 13, 2024 3:45:08 AM MST Clément Lassieur wrote:
> On Mon, Oct 16 2023, Soren Stoutner via Guix-patches via wrote:
> > Note that for KHelpCenter to function, it must be specified at runtime.  
For
> > example:
> > 
> > guix shell privacybrowser khelpcenter -- privacybrowser
> 
> Maybe it should be a propagated input then?

How is that done?

> Also does it have to be in a specific file?  I imagine it could fit in
> qt.scm?

You can put it wherever it makes the most sense.  If you would like to place 
it inside of another scm, I would imagine that web-browsers.scm is probably 
the most logical location.
Clément Lassieur Jan. 14, 2024, 9:17 a.m. UTC | #7
On Sat, Jan 13 2024, Soren Stoutner via Guix-patches via wrote:

> Clément
>
> On Saturday, January 13, 2024 3:45:08 AM MST Clément Lassieur wrote:
>> On Mon, Oct 16 2023, Soren Stoutner via Guix-patches via wrote:
>> > Note that for KHelpCenter to function, it must be specified at runtime.  
> For
>> > example:
>> > 
>> > guix shell privacybrowser khelpcenter -- privacybrowser
>> 
>> Maybe it should be a propagated input then?

You use the propagated-inputs field instead of the inputs field.  The
consequence is that installing "PrivacyBrowser" will install the
propagated inputs too.  Same with "guix shell".  So "guix shell
privacybrowser -- privacybrowser" will work.

> How is that done?
>
>> Also does it have to be in a specific file?  I imagine it could fit in
>> qt.scm?
>
> You can put it wherever it makes the most sense.  If you would like to place 
> it inside of another scm, I would imagine that web-browsers.scm is probably 
> the most logical location.

Indeed, sounds like the right place.

Can you send an updated patch?
diff mbox series

Patch

diff --git a/gnu/packages/privacybrowser.scm b/gnu/packages/privacybrowser.scm
new file mode 100644
index 0000000000..e0cf871f85
--- /dev/null
+++ b/gnu/packages/privacybrowser.scm
@@ -0,0 +1,58 @@ 
+;;; Privacy Browser PC --- A web browser that respects your privacy.
+;;; Copyright © 2023 Soren Stoutner <soren@stoutner.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages privacybrowser)
+  #:use-module (guix build-system qt)
+  #:use-module (guix download)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (gnu packages kde-frameworks)
+  #:use-module (gnu packages kde-systemtools)
+  #:use-module (gnu packages qt))
+
+(define-public privacybrowser
+  (package
+    (name "privacybrowser")
+    (version "0.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://download.stoutner.com/privacybrowser-pc/privacybrowser-"
+                    version ".tar.xz"))
+              (sha256
+               (base32
+                "1c458n2g4zic5fizn2mir0nah28f0yp7swdyy6xk5hqg7nxk2akc"))))
+    (build-system qt-build-system)
+    (native-inputs (list extra-cmake-modules))
+    (inputs (list breeze-icons
+                  kcrash
+                  kdbusaddons
+                  khelpcenter
+                  ki18n
+                  kio
+                  knotifications
+                  qtsvg-5
+                  qtwebengine-5))
+    (home-page "https://www.stoutner.com/privacy-browser-pc/")
+    (synopsis "Web browser that respects your privacy")
+    (description
+     "Privacy Browser is a web browser based on Qt WebEngine
+with a focus on privacy and security.  Features like JavaScript and
+cookies are disabled by default but are easy to automatically enable
+on-the-fly or by domain.")
+    (license gpl3+)))