diff mbox series

[bug#64400,4/5] gnu: Add ocaml-toml.

Message ID 20230701174258.21019-4-anders@aathn.org
State New
Headers show
Series [bug#64400,1/5] gnu: Add ocaml-ISO8601. | expand

Commit Message

Anders Ågren Thuné July 1, 2023, 5:43 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-toml): New variable.
---
 gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 083c1aca99..83077addb0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2772,6 +2772,31 @@  (define-public ocaml-npy
 from python using numpy.")
     (license license:asl2.0)))
 
+(define-public ocaml-toml
+  (package
+    (name "ocaml-toml")
+    (version "7.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ocaml-toml/to.ml")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0z2873mj3i6h9cg8zlkipcjab8jympa4c4avhk4l04755qzphkds"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-odoc ocaml-ISO8601))
+    (native-inputs
+     (list ocaml-menhir ocaml-ounit2 ocaml-mdx ocaml-bisect-ppx ocaml-ocb))
+    (home-page "https://ocaml-toml.github.io/To.ml/")
+    (synopsis "Library for TOML with a parser, a serializer and a printer")
+    (description
+     "toml is an OCaml library providing a parser, a serializer and a printer for
+TOML, a minimal configuration file format.  Helpful getters to retrieve data as
+OCaml primitive types are also supplied.")
+    (license license:lgpl3)))
+
 (define-public ocaml-parmap
   (package
     (name "ocaml-parmap")