diff mbox series

[bug#64400,3/5] gnu: Add ocaml-npy.

Message ID 20230701174258.21019-3-anders@aathn.org
State New
Headers show
Series [bug#64400,1/5] gnu: Add ocaml-ISO8601. | expand

Commit Message

Anders Ågren Thuné July 1, 2023, 5:43 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-npy): New variable.
---
 gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f2170a3060..083c1aca99 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2748,6 +2748,30 @@  (define-public ocaml-ocb
 provided.")
     (license license:isc)))
 
+(define-public ocaml-npy
+  (package
+    (name "ocaml-npy")
+    (version "0.0.9")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/LaurentMazare/npy-ocaml")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1fryglkm20h6kdqjl55b7065b34bdg3g3p6j0jv33zvd1m5888m1"))))
+    (build-system dune-build-system)
+    (native-inputs (list zlib python-wrapper python-numpy))
+    (propagated-inputs (list camlzip))
+    (home-page "https://github.com/LaurentMazare/npy-ocaml")
+    (synopsis "Numpy npy file format reading/writing for OCaml")
+    (description
+     "A library providing simple read/write function using the numpy npy/npz
+file formats.  These can be used to save a bigarray to disk and then load it
+from python using numpy.")
+    (license license:asl2.0)))
+
 (define-public ocaml-parmap
   (package
     (name "ocaml-parmap")