diff mbox series

[bug#64400,2/5] gnu: Add ocaml-ocb.

Message ID 20230701174258.21019-2-anders@aathn.org
State New
Headers show
Series [bug#64400,1/5] gnu: Add ocaml-ISO8601. | expand

Commit Message

Anders Ågren Thuné July 1, 2023, 5:43 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ocb): New variable.
---
 gnu/packages/ocaml.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Liliana Marie Prikler July 11, 2023, 6:31 p.m. UTC | #1
Am Samstag, dem 01.07.2023 um 17:43 +0000 schrieb Anders Ågren Thuné:
> * gnu/packages/ocaml.scm (ocaml-ocb): New variable.
> ---
>  gnu/packages/ocaml.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
> 
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index abdf09bdc1..f2170a3060 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -2726,6 +2726,28 @@ (define-public ocaml-ISO8601
>         "OCaml parser and printer for date-times in ISO8601 and RFC
> 3339")
>        (license license:expat))))
>  
> +(define-public ocaml-ocb
> +  (package
> +    (name "ocaml-ocb")
> +    (version "0.2")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/OCamlPro/ocb")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "1nk90jax91ld8qd36qi408mll8a7w1d60fa2qdsnff7cldwixc1d"))))
> +    (build-system dune-build-system)
> +    (propagated-inputs (list ocaml-odoc))
> +    (home-page "https://ocamlpro.github.io/ocb/")
> +    (synopsis "SVG badge generator")
> +    (description
> +     "An OCaml library for SVG badge generation.  There's also a
> command-line tool
> +provided.")
"This package provides an OCaml library and command-line tool for
creating SVG badges" :)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index abdf09bdc1..f2170a3060 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2726,6 +2726,28 @@  (define-public ocaml-ISO8601
        "OCaml parser and printer for date-times in ISO8601 and RFC 3339")
       (license license:expat))))
 
+(define-public ocaml-ocb
+  (package
+    (name "ocaml-ocb")
+    (version "0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/OCamlPro/ocb")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1nk90jax91ld8qd36qi408mll8a7w1d60fa2qdsnff7cldwixc1d"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-odoc))
+    (home-page "https://ocamlpro.github.io/ocb/")
+    (synopsis "SVG badge generator")
+    (description
+     "An OCaml library for SVG badge generation.  There's also a command-line tool
+provided.")
+    (license license:isc)))
+
 (define-public ocaml-parmap
   (package
     (name "ocaml-parmap")