diff mbox series

[bug#64400,1/5] gnu: Add ocaml-ISO8601.

Message ID 20230701174258.21019-1-anders@aathn.org
State New
Headers show
Series [bug#64400,1/5] gnu: Add ocaml-ISO8601. | expand

Commit Message

Anders Ågren Thuné July 1, 2023, 5:43 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ISO8601): New variable.
---
 gnu/packages/ocaml.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Liliana Marie Prikler July 11, 2023, 6:30 p.m. UTC | #1
Am Samstag, dem 01.07.2023 um 17:43 +0000 schrieb Anders Ågren Thuné:
> * gnu/packages/ocaml.scm (ocaml-ISO8601): New variable.
> ---
>  gnu/packages/ocaml.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
> 
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index ab0aa0574a..abdf09bdc1 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -29,6 +29,7 @@
>  ;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
>  ;;; Copyright © 2023 Csepp <raingloom@riseup.net>
>  ;;; Copyright © 2023 Foundation Devices, Inc.
> <hello@foundationdevices.com>
> +;;; Copyright © 2023 Anders Ågren Thuné <anders@aathn.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -2699,6 +2700,32 @@ (define-public ocaml-ppx-tools
>  syntactic tools.")
>      (license license:expat)))
>  
> +(define-public ocaml-ISO8601
> +  ;; NOTE: Using commit from master branch as 0.2.6 uses the
> Pervasives
> +  ;; module in its tests, which is incompatible with OCaml 5.0.
> +  (let ((revision "0")
> +        (commit "ad50cb01061405623c834608c26f1ef2d44f8340"))
> +    (package
> +      (name "ocaml-ISO8601")
> +      (version (git-version "0.2.6" revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url
> "https://github.com/ocaml-community/ISO8601.ml")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                 
> "1lvjrxz66b7dv40cbl8xyfv3x8nmwj0m5ipfvxc37mjaaf3xrr5g"))))
> +      (build-system dune-build-system)
> +      (propagated-inputs (list ocaml-odoc))
> +      (native-inputs (list ocaml-ounit))
> +      (home-page "https://github.com/ocaml-community/ISO8601.ml/")
> +      (synopsis "ISO 8601 and RFC 3339 date parsing for OCaml")
Can probably be shortened to "OCaml date parsing"
> +      (description
> +       "OCaml parser and printer for date-times in ISO8601 and RFC
> 3339")
The description should consist at least of one complete sentence.  The
typical go to pattern here if information is scarce is "this package
provides…" as in "This package provides an OCaml library with parsers
and printers for date times in ISO 8601 and RFC 3339 formats."

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ab0aa0574a..abdf09bdc1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -29,6 +29,7 @@ 
 ;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
 ;;; Copyright © 2023 Csepp <raingloom@riseup.net>
 ;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;; Copyright © 2023 Anders Ågren Thuné <anders@aathn.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2699,6 +2700,32 @@  (define-public ocaml-ppx-tools
 syntactic tools.")
     (license license:expat)))
 
+(define-public ocaml-ISO8601
+  ;; NOTE: Using commit from master branch as 0.2.6 uses the Pervasives
+  ;; module in its tests, which is incompatible with OCaml 5.0.
+  (let ((revision "0")
+        (commit "ad50cb01061405623c834608c26f1ef2d44f8340"))
+    (package
+      (name "ocaml-ISO8601")
+      (version (git-version "0.2.6" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/ocaml-community/ISO8601.ml")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1lvjrxz66b7dv40cbl8xyfv3x8nmwj0m5ipfvxc37mjaaf3xrr5g"))))
+      (build-system dune-build-system)
+      (propagated-inputs (list ocaml-odoc))
+      (native-inputs (list ocaml-ounit))
+      (home-page "https://github.com/ocaml-community/ISO8601.ml/")
+      (synopsis "ISO 8601 and RFC 3339 date parsing for OCaml")
+      (description
+       "OCaml parser and printer for date-times in ISO8601 and RFC 3339")
+      (license license:expat))))
+
 (define-public ocaml-parmap
   (package
     (name "ocaml-parmap")