diff mbox series

[bug#64289] gnu: Add python-deepxde.

Message ID 20230625222916.82599-1-monego@posteo.net
State New
Headers show
Series [bug#64289] gnu: Add python-deepxde. | expand

Commit Message

Vinicius Monego June 25, 2023, 10:29 p.m. UTC
* gnu/packages/machine-learning.scm (python-deepxde): New variable.
---
 gnu/packages/machine-learning.scm | 33 +++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)


base-commit: 41e8726c8924e9f5b79a9f44fad94ab5586bfc50

Comments

Ludovic Courtès July 18, 2023, 11:42 a.m. UTC | #1
Vinicius Monego <monego@posteo.net> skribis:

> * gnu/packages/machine-learning.scm (python-deepxde): New variable.

[...]

> +    (home-page "https://deepxde.readthedocs.io/en/latest/")
> +    (synopsis "Library for scientific machine learning")
> +    (description "DeepXDE is a library for scientific machine learning and
> +physics-informed learning.  It includes implementations for the PINN
> +(physics-informed neural networks), DeepONet (deep operator network) and
> +MFNN (multifidelity neural network) algorithms.")
> +    (license license:lgpl2.1)))

Since source file headers don’t say anything, that’s ‘lgpl2.1+’.

Otherwise LGTM, thanks!
Vinicius Monego July 29, 2023, 6:42 p.m. UTC | #2
Em ter, 2023-07-18 às 13:42 +0200, Ludovic Courtès escreveu:

> 
> > * gnu/packages/machine-learning.scm (python-deepxde): New variable.
> 
> [...]
> 
> Since source file headers don’t say anything, that’s ‘lgpl2.1+’.
> 
> Otherwise LGTM, thanks!

Applied with this change, thanks.
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 8fbb0274d4..ddb773b8ce 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1936,6 +1936,39 @@  (define-public python-hyperopt
 discrete, and conditional dimensions.")
     (license license:bsd-3)))
 
+(define-public python-deepxde
+  (package
+    (name "python-deepxde")
+    (version "1.9.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "DeepXDE" version))
+              (sha256
+               (base32
+                "0gibr0nz8xfhxwi2rgfypm653fy912n49161vqaqgpxlm2pb3bhb"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f                  ; there are no tests
+           #:phases #~(modify-phases %standard-phases
+                        (add-before 'sanity-check 'writable-home
+                          ;; sanity-check writes ~/.deepxde/config.json to set
+                          ;; the default backend.
+                          (lambda _
+                            (setenv "HOME" "/tmp"))))))
+    ;; DeepXDE supported backends are TensorFlow (v1 and v2), PyTorch, JAX and
+    ;; PaddlePaddle.  We test with PyTorch because we have it up to date.
+    (native-inputs (list python-pytorch python-setuptools-scm))
+    (propagated-inputs (list python-matplotlib python-numpy
+                             python-scikit-learn python-scikit-optimize
+                             python-scipy))
+    (home-page "https://deepxde.readthedocs.io/en/latest/")
+    (synopsis "Library for scientific machine learning")
+    (description "DeepXDE is a library for scientific machine learning and
+physics-informed learning.  It includes implementations for the PINN
+(physics-informed neural networks), DeepONet (deep operator network) and
+MFNN (multifidelity neural network) algorithms.")
+    (license license:lgpl2.1)))
+
 ;; There have been no proper releases yet.
 (define-public kaldi
   (let ((commit "be22248e3a166d9ec52c78dac945f471e7c3a8aa")