diff mbox series

[bug#64100] gnu: llvm: make clang-make-toolchain public

Message ID 20230615180514.1042827-1-lists@coryfields.com
State New
Headers show
Series [bug#64100] gnu: llvm: make clang-make-toolchain public | expand

Commit Message

lists@coryfields.com June 15, 2023, 6:05 p.m. UTC
From: Cory Fields <cory-nospam-@coryfields.com>

Matches gcc-make-toolchain. Allow for llvm build to be patched.

* gnu/packages/llvm.scm: make clang-make-toolchain public

Signed-off-by: Cory Fields <cory-nospam-@coryfields.com>
---
 gnu/packages/llvm.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 6e1215fb9c03ccb4a2d4440990aee5a66a935268

Comments

Carl Dong June 16, 2023, 8:40 p.m. UTC | #1
Simple enough and matches gcc-make-toolchain.

Allows for more complex manifests and packages to be built with a custom clang toolchains without forking Guix.

I think I still have push rights so I’ll push in 2 weeks if there are no other objections (this shouldn’t trigger any rebuilds at all).

–Carl

> On Jun 15, 2023, at 2:05 PM, lists@coryfields.com wrote:
> 
> From: Cory Fields <cory-nospam-@coryfields.com>
> 
> Matches gcc-make-toolchain. Allow for llvm build to be patched.
> 
> * gnu/packages/llvm.scm: make clang-make-toolchain public
> 
> Signed-off-by: Cory Fields <cory-nospam-@coryfields.com>
> ---
> gnu/packages/llvm.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
> index f59c8e9592..6d83313af6 100644
> --- a/gnu/packages/llvm.scm
> +++ b/gnu/packages/llvm.scm
> @@ -502,7 +502,7 @@ code analysis tools.")
>               "znver3")
>             '())))))
> 
> -(define (make-clang-toolchain clang libomp)
> +(define-public (make-clang-toolchain clang libomp)
>   (package
>     (name (string-append (package-name clang) "-toolchain"))
>     (version (package-version clang))
> 
> base-commit: 6e1215fb9c03ccb4a2d4440990aee5a66a935268
> -- 
> 2.25.1
> 
> 
> 
>
Efraim Flashner June 18, 2023, 6:38 a.m. UTC | #2
On Fri, Jun 16, 2023 at 04:40:22PM -0400, Carl Dong wrote:
> Simple enough and matches gcc-make-toolchain.
> 
> Allows for more complex manifests and packages to be built with a custom clang toolchains without forking Guix.
> 
> I think I still have push rights so I’ll push in 2 weeks if there are no other objections (this shouldn’t trigger any rebuilds at all).

Sounds good to me

> > On Jun 15, 2023, at 2:05 PM, lists@coryfields.com wrote:
> > 
> > From: Cory Fields <cory-nospam-@coryfields.com>
> > 
> > Matches gcc-make-toolchain. Allow for llvm build to be patched.
> > 
> > * gnu/packages/llvm.scm: make clang-make-toolchain public
> > 
> > Signed-off-by: Cory Fields <cory-nospam-@coryfields.com>
> > ---
> > gnu/packages/llvm.scm | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
> > index f59c8e9592..6d83313af6 100644
> > --- a/gnu/packages/llvm.scm
> > +++ b/gnu/packages/llvm.scm
> > @@ -502,7 +502,7 @@ code analysis tools.")
> >               "znver3")
> >             '())))))
> > 
> > -(define (make-clang-toolchain clang libomp)
> > +(define-public (make-clang-toolchain clang libomp)
> >   (package
> >     (name (string-append (package-name clang) "-toolchain"))
> >     (version (package-version clang))
> > 
> > base-commit: 6e1215fb9c03ccb4a2d4440990aee5a66a935268
> > -- 
> > 2.25.1
> > 
> > 
> > 
> > 
>
Michael Ford June 19, 2023, 1:50 p.m. UTC | #3
> Matches gcc-make-toolchain. Allow for llvm build to be patched.
> * gnu/packages/llvm.scm: make clang-make-toolchain public

This is great. Thanks for the change.
Definitely useful for downstream Guix users!
Carl Dong July 2, 2023, 5:16 p.m. UTC | #4
Pushed to master as 39a3251feb2559e0b448f25671c26b9dd3318108

I’m not sure I can close this ticket as I didn’t open it.

–Carl

> On Jun 18, 2023, at 2:38 AM, Efraim Flashner <efraim@flashner.co.il> wrote:
> 
> On Fri, Jun 16, 2023 at 04:40:22PM -0400, Carl Dong wrote:
>> Simple enough and matches gcc-make-toolchain.
>> 
>> Allows for more complex manifests and packages to be built with a custom clang toolchains without forking Guix.
>> 
>> I think I still have push rights so I’ll push in 2 weeks if there are no other objections (this shouldn’t trigger any rebuilds at all).
> 
> Sounds good to me
> 
>>> On Jun 15, 2023, at 2:05 PM, lists@coryfields.com wrote:
>>> 
>>> From: Cory Fields <cory-nospam-@coryfields.com>
>>> 
>>> Matches gcc-make-toolchain. Allow for llvm build to be patched.
>>> 
>>> * gnu/packages/llvm.scm: make clang-make-toolchain public
>>> 
>>> Signed-off-by: Cory Fields <cory-nospam-@coryfields.com>
>>> ---
>>> gnu/packages/llvm.scm | 2 +-
>>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>> 
>>> diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
>>> index f59c8e9592..6d83313af6 100644
>>> --- a/gnu/packages/llvm.scm
>>> +++ b/gnu/packages/llvm.scm
>>> @@ -502,7 +502,7 @@ code analysis tools.")
>>>              "znver3")
>>>            '())))))
>>> 
>>> -(define (make-clang-toolchain clang libomp)
>>> +(define-public (make-clang-toolchain clang libomp)
>>>  (package
>>>    (name (string-append (package-name clang) "-toolchain"))
>>>    (version (package-version clang))
>>> 
>>> base-commit: 6e1215fb9c03ccb4a2d4440990aee5a66a935268
>>> --
>>> 2.25.1
>>> 
>>> 
>>> 
>>> 
>> 
> 
> --
> Efraim Flashner   <efraim@flashner.co.il>   רנשלפ םירפא
> GPG key = A28B F40C 3E55 1372 662D  14F7 41AA E7DC CA3D 8351
> Confidentiality cannot be guaranteed on emails sent or received unencrypted
diff mbox series

Patch

diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index f59c8e9592..6d83313af6 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -502,7 +502,7 @@  code analysis tools.")
               "znver3")
             '())))))
 
-(define (make-clang-toolchain clang libomp)
+(define-public (make-clang-toolchain clang libomp)
   (package
     (name (string-append (package-name clang) "-toolchain"))
     (version (package-version clang))