diff mbox series

[bug#63980] gnu: python-typeguard: Add dependency on python-setuptools-scm.

Message ID 20230609155229.2656864-1-monego@posteo.net
State New
Headers show
Series [bug#63980] gnu: python-typeguard: Add dependency on python-setuptools-scm. | expand

Commit Message

Vinicius Monego June 9, 2023, 3:52 p.m. UTC
* gnu/packages/python-xyz.scm (python-typeguard)[native-inputs]: Add
python-setuptools-scm.
---
This is required to report the correct version.

 gnu/packages/python-xyz.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès July 1, 2023, 9:25 p.m. UTC | #1
Hi,

Vinicius Monego <monego@posteo.net> skribis:

> * gnu/packages/python-xyz.scm (python-typeguard)[native-inputs]: Add
> python-setuptools-scm.

LGTM!

<https://qa.guix.gnu.org/issue/63980> says it’s OK; the “Blocked”
numbers are higher, but I’m not sure what that means since there are no
new packages here.  Chris, WDYT?

Thanks,
Ludo’.
Christopher Baines July 2, 2023, 9:45 a.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hi,
>
> Vinicius Monego <monego@posteo.net> skribis:
>
>> * gnu/packages/python-xyz.scm (python-typeguard)[native-inputs]: Add
>> python-setuptools-scm.
>
> LGTM!
>
> <https://qa.guix.gnu.org/issue/63980> says it’s OK; the “Blocked”
> numbers are higher, but I’m not sure what that means since there are no
> new packages here.  Chris, WDYT?

This is an issue with the data service incorrectly seeing some builds as
not blocked, when they should be. Some of the builds in the base
revision that are being counted in the "Unknown" column should actually
be in blocked, which is why the blocked count appears to increase.

I'm not quite sure what the issue is, but I'll have another look at
fixing this.
Vinicius Monego July 29, 2023, 6:53 p.m. UTC | #3
Hi,

Em dom, 2023-07-02 às 10:45 +0100, Christopher Baines escreveu:
> 
> Ludovic Courtès <ludo@gnu.org> writes:
> 
> > Hi,
> > 
> > Vinicius Monego <monego@posteo.net> skribis:
> > 
> > > * gnu/packages/python-xyz.scm (python-typeguard)[native-inputs]:
> > > Add
> > > python-setuptools-scm.
> > 
> > LGTM!
> > 
> > <https://qa.guix.gnu.org/issue/63980> says it’s OK; the “Blocked”
> > numbers are higher, but I’m not sure what that means since there
> > are no
> > new packages here.  Chris, WDYT?
> 
> This is an issue with the data service incorrectly seeing some builds
> as
> not blocked, when they should be. Some of the builds in the base
> revision that are being counted in the "Unknown" column should
> actually
> be in blocked, which is why the blocked count appears to increase.
> 
> I'm not quite sure what the issue is, but I'll have another look at
> fixing this.

If it's a problem in the data service only, can I push this to master?
There are 257 rebuilds with this change (including pytorch) and I want
to add another one in https://issues.guix.gnu.org/63621 before it hits
300.

Vinicius
Ludovic Courtès Sept. 8, 2023, 9:51 p.m. UTC | #4
Hi Vinicius,

Vinicius Monego <monego@posteo.net> skribis:

> If it's a problem in the data service only, can I push this to master?
> There are 257 rebuilds with this change (including pytorch) and I want
> to add another one in https://issues.guix.gnu.org/63621 before it hits
> 300.

I think you can go ahead and push both series (assuming that at least
‘python-pytorch’ is fine after these changes).

Thanks,
Ludo’.
Vinicius Monego Sept. 17, 2023, 11:29 a.m. UTC | #5
Em sex, 2023-09-08 às 23:51 +0200, Ludovic Courtès escreveu:
> Hi Vinicius,
> 
> Vinicius Monego <monego@posteo.net> skribis:
> 
> > If it's a problem in the data service only, can I push this to
> > master?
> > There are 257 rebuilds with this change (including pytorch) and I
> > want
> > to add another one in https://issues.guix.gnu.org/63621 before it
> > hits
> > 300.
> 
> I think you can go ahead and push both series (assuming that at least
> ‘python-pytorch’ is fine after these changes).
> 
> Thanks,
> Ludo’.

Hi Ludo,

Closing this one because I applied it. I pushed only part of the other
because the latest version of BoTorch is having issues with reporting
its version, I will look further into it.

Vinicius
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7d5128911f..351e199e57 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23453,8 +23453,10 @@  (define-public python-typeguard
                         ;; XXX: These fail when installed as a library:
                         ;; https://github.com/agronholm/typeguard/issues/176
                         "not usefixtures and not test_cached_module")))))))
-    (native-inputs
-     (list python-mypy python-pytest python-typing-extensions))
+    (native-inputs (list python-mypy
+                         python-pytest
+                         python-setuptools-scm
+                         python-typing-extensions))
     (home-page "https://github.com/agronholm/typeguard")
     (synopsis "Run-time type checker for Python")
     (description