diff mbox series

[bug#63900] gnu: Add emacs-fb2-reader.

Message ID 20230604163021.5163-1-4164616d.4b616e647572@gmail.com
State New
Headers show
Series [bug#63900] gnu: Add emacs-fb2-reader. | expand

Commit Message

Adam Kandur June 4, 2023, 4:30 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-fb2-reader): New variable.
---
 gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Nicolas Goaziou June 5, 2023, 4:15 p.m. UTC | #1
Hello,

Adam Kandur <4164616d.4b616e647572@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-fb2-reader): New variable.

Thank you. Some comments follow. 

> +(define-public emacs-fb2-reader
> +  (let ((revision "0")
> +        ;; named branch is outdated
> +        (commit "9836db284749e0cef4c43c2cb5358c82ae9b8589"))

This exactly matches version 0.1.1 so you should add "; version bump"
comment at the end of the line, and use 0.1.1 as the version.

> +      (native-inputs
> +       (list emacs-buttercup
> +             emacs-dash
> +             emacs-s
> +             emacs-async))

There are tests, could you try running them?

Note that inputs should be ordered alphabetically.

> +      (propagated-inputs
> +       (list emacs-visual-fill-column
> +             emacs-f
> +             unzip))

Likewise.

Also, unzip should be an input rather than a propagated input, and
"fb2-reader.el" should be patched accordingly (i.e., replacing

  "unzip"

with

  (search-input-files inputs "/bin/unzip"))

> +      (home-page "https://github.com/jumper047/fb2-reader")
> +      (synopsis "Emacs plugin to read .fb2 and .fb2.zip ebooks")

I suggest:

  Emacs plugin to read FictionBook2 ebooks

> +      (description "This package allows users to read fb2 books
> +whithout quiting Emacs.")

What about:

  FB2 Reader provides a major mode for reading FictionBook2 (@file{.fb2}
  and @file{.fb2.zip} files) ebooks.

> +      (license license:gpl3))))

License is actually gpl3+, as mentioned in the main file.

Could you send an updated patch?

Regards,
Adam Kandur June 6, 2023, 8:35 p.m. UTC | #2
Sure, I will try make a new patch this week

On Mon, Jun 5, 2023 at 7:15 PM Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
>
> Hello,
>
> Adam Kandur <4164616d.4b616e647572@gmail.com> writes:
>
> > * gnu/packages/emacs-xyz.scm (emacs-fb2-reader): New variable.
>
> Thank you. Some comments follow.
>
> > +(define-public emacs-fb2-reader
> > +  (let ((revision "0")
> > +        ;; named branch is outdated
> > +        (commit "9836db284749e0cef4c43c2cb5358c82ae9b8589"))
>
> This exactly matches version 0.1.1 so you should add "; version bump"
> comment at the end of the line, and use 0.1.1 as the version.
>
> > +      (native-inputs
> > +       (list emacs-buttercup
> > +             emacs-dash
> > +             emacs-s
> > +             emacs-async))
>
> There are tests, could you try running them?
>
> Note that inputs should be ordered alphabetically.
>
> > +      (propagated-inputs
> > +       (list emacs-visual-fill-column
> > +             emacs-f
> > +             unzip))
>
> Likewise.
>
> Also, unzip should be an input rather than a propagated input, and
> "fb2-reader.el" should be patched accordingly (i.e., replacing
>
>   "unzip"
>
> with
>
>   (search-input-files inputs "/bin/unzip"))
>
> > +      (home-page "https://github.com/jumper047/fb2-reader")
> > +      (synopsis "Emacs plugin to read .fb2 and .fb2.zip ebooks")
>
> I suggest:
>
>   Emacs plugin to read FictionBook2 ebooks
>
> > +      (description "This package allows users to read fb2 books
> > +whithout quiting Emacs.")
>
> What about:
>
>   FB2 Reader provides a major mode for reading FictionBook2 (@file{.fb2}
>   and @file{.fb2.zip} files) ebooks.
>
> > +      (license license:gpl3))))
>
> License is actually gpl3+, as mentioned in the main file.
>
> Could you send an updated patch?
>
> Regards,
> --
> Nicolas Goaziou
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b77bd0aa83..f563063d7f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1632,6 +1632,38 @@  (define-public emacs-fzf
 purpose finder.")
       (license license:gpl3+))))
 
+(define-public emacs-fb2-reader
+  (let ((revision "0")
+        ;; named branch is outdated
+        (commit "9836db284749e0cef4c43c2cb5358c82ae9b8589"))
+    (package
+      (name "emacs-fb2-reader")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+	 (method git-fetch)
+	 (uri (git-reference
+	       (url "https://github.com/jumper047/fb2-reader")
+	       (commit commit)))
+	 (file-name (git-file-name name version))
+	 (sha256
+	  (base32 "0vx4b9wnmx1bng8wak5r7yryyvgib4m46l6b877xzkdhsjr3rbsi"))))
+      (build-system emacs-build-system)
+      (native-inputs
+       (list emacs-buttercup
+             emacs-dash
+             emacs-s
+             emacs-async))
+      (propagated-inputs
+       (list emacs-visual-fill-column
+             emacs-f
+             unzip))
+      (home-page "https://github.com/jumper047/fb2-reader")
+      (synopsis "Emacs plugin to read .fb2 and .fb2.zip ebooks")
+      (description "This package allows users to read fb2 books
+whithout quiting Emacs.")
+      (license license:gpl3))))
+
 (define-public emacs-minions
   (package
     (name "emacs-minions")