diff mbox series

[bug#63847,core-updates] gnu: libinput: Update to 1.23.0.

Message ID 20230602145113.10433-1-hako@ultrarare.space
State New
Headers show
Series [bug#63847,core-updates] gnu: libinput: Update to 1.23.0. | expand

Commit Message

Hilton Chain June 2, 2023, 2:51 p.m. UTC
* gnu/packages/freedesktop.scm (libinput): Update to 1.23.0.
[source]: Add file-name field.
[native-inputs]: Add python-minimal-wrapper and python-pytest.
---
 gnu/packages/freedesktop.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)


base-commit: a7d9cd742c3149bb014db95f88d1158d590bc124

Comments

Hilton Chain Aug. 25, 2023, 7:11 a.m. UTC | #1
On Fri, 02 Jun 2023 22:51:13 +0800,
Hilton Chain wrote:
> 
> * gnu/packages/freedesktop.scm (libinput): Update to 1.23.0.
> [source]: Add file-name field.
> [native-inputs]: Add python-minimal-wrapper and python-pytest.
> ---

Close since it's applied to core-updates and a new version is
available, I'll send a new patch for that.
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6385741d89..3fc73a0822 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -557,15 +557,16 @@  (define-public libinput
   ;; Updating this will rebuild over 700 packages through libinput-minimal.
   (package
     (name "libinput")
-    (version "1.22.1")
+    (version "1.23.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://gitlab.freedesktop.org/libinput/libinput.git")
                     (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "17a5qlym2d6lg2j8fdpxda9k7x5zr35flb4wlj1bz7h0mnkh8326"))))
+                "0wnqfnxxvf9jclh64hrb0scn3s1dmwdkmqf7hp0cfmjz5n5nnv7d"))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags '("-Ddocumentation=false")
@@ -575,7 +576,7 @@  (define-public libinput
        ;; Meson target anyway.
        #:build-type "release"))
     (native-inputs
-     (list check pkg-config))
+     (list check pkg-config python-minimal-wrapper python-pytest))
     (inputs
      (list cairo
            glib