diff mbox series

[bug#63782,1/2] gnu: Add qbittorrent-enhanced.

Message ID 20230529070109.768-1-hako@ultrarare.space
State New
Headers show
Series [bug#63782,1/2] gnu: Add qbittorrent-enhanced. | expand

Commit Message

Hilton Chain May 29, 2023, 7:01 a.m. UTC
* gnu/packages/bittorrent.scm (qbittorrent-enhanced): New variable.
---
 gnu/packages/bittorrent.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: d64d6ea2cf5a1be801be355031fb2cfa5901a92a

Comments

Nicolas Goaziou July 1, 2023, 10:09 a.m. UTC | #1
Hello,

Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/bittorrent.scm (qbittorrent-enhanced): New variable.

Applied. Thank you.

> +    (description
> +     "qBittorrent Enhanced is a bittorrent client based on qBittorrent with
> +the following features:
> +
> +@itemize
> +@item Auto Ban Xunlei, QQ, Baidu, Xfplay, DLBT and Offline downloader
> +@item Auto Ban Unknown Peer from China Option (Default: OFF)
> +@item Auto Update Public Trackers List (Default: OFF)
> +@item Auto Ban BitTorrent Media Player Peer Option (Default: OFF)
> +@item Peer whitelist/blacklist
> +@end itemize\n")))

Note the newline character is not necessary at the end of the
description. I removed it.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 38e959b884..acec7a48d9 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -519,6 +519,33 @@  (define-public qbittorrent-nox
        (modify-inputs (package-inputs base)
          (delete "qtsvg-5"))))))
 
+(define-public qbittorrent-enhanced
+  (package
+    (inherit qbittorrent)
+    (name "qbittorrent-enhanced")
+    (version "4.5.2.10")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/c0re100/qBittorrent-Enhanced-Edition")
+                    (commit (string-append "release-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "18z4panaqbmhbw5i1yn17wpqzslhy6w08zcc5bx2hhlg8slp1r9j"))))
+    (home-page "https://github.com/c0re100/qBittorrent-Enhanced-Edition")
+    (description
+     "qBittorrent Enhanced is a bittorrent client based on qBittorrent with
+the following features:
+
+@itemize
+@item Auto Ban Xunlei, QQ, Baidu, Xfplay, DLBT and Offline downloader
+@item Auto Ban Unknown Peer from China Option (Default: OFF)
+@item Auto Update Public Trackers List (Default: OFF)
+@item Auto Ban BitTorrent Media Player Peer Option (Default: OFF)
+@item Peer whitelist/blacklist
+@end itemize\n")))
+
 (define-public deluge
   (package
     (name "deluge")