diff mbox series

[bug#63765,4/8] gnu: mbedtls-apache-for-hiawatha: Use inherited source.

Message ID 20230528081107.24209-4-hako@ultrarare.space
State New
Headers show
Series gnu: python-lief: Update to 0.13.0. | expand

Commit Message

Hilton Chain May 28, 2023, 8:11 a.m. UTC
* gnu/packages/tls.scm (mbedtls-apache-for-hiawatha): Use inherited source.
[arguments]<#:phases>: Keep "-Wformat-signedness".
---
 gnu/packages/tls.scm | 25 -------------------------
 1 file changed, 25 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index cd5933a270..1e2b0fcc20 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -944,8 +944,6 @@  (define-public perl-crypt-openssl-random
 (define-public mbedtls-apache-lts
   (package
     (name "mbedtls-apache")
-    ;; XXX Check whether ‘-Wformat-signedness’ still breaks mbedtls-for-hiawatha
-    ;; when updating.
     (version "2.28.0")
     (source
      (origin
@@ -982,26 +980,6 @@  (define-public mbedtls-for-hiawatha
   (hidden-package
    (package
      (inherit mbedtls-apache-lts)
-     (name "mbedtls-apache")
-     (version "2.26.0")
-     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-              (url "https://github.com/ARMmbed/mbedtls")
-              (commit (string-append "mbedtls-" version))))
-        (sha256
-         (base32 "0scwpmrgvg6q7rvqkc352d2fqlsx0aylcbyibcp1f1rsn8iiif2m"))
-        (file-name (git-file-name name version))
-        (modules '((guix build utils)))
-        (snippet
-         '(begin
-            ;; Can be removed with the next version.
-            ;; Reduce level of format truncation warnings due to false positives.
-            ;; https://github.com/ARMmbed/mbedtls/commit/2065a8d8af27c6cb1e40c9462b5933336dca7434
-            (substitute* "CMakeLists.txt"
-              (("Wformat-truncation=2") "Wformat-truncation"))
-            #t))))
      (arguments
       (substitute-keyword-arguments (package-arguments mbedtls-apache-lts)
         ((#:phases phases)
@@ -1012,9 +990,6 @@  (define-public mbedtls-for-hiawatha
                             (invoke "scripts/config.pl" "set" feature))
                           (list "MBEDTLS_THREADING_C"
                                 "MBEDTLS_THREADING_PTHREAD"))
-                ;; XXX The above enables code that breaks with -Werror…
-                (substitute* "CMakeLists.txt"
-                  ((" -Wformat-signedness") ""))
                 #t)))))))))
 
 (define-public dehydrated