diff mbox series

[bug#63765,2/8] gnu: utfcpp: Update to 3.2.3.

Message ID 20230528081107.24209-2-hako@ultrarare.space
State New
Headers show
Series gnu: python-lief: Update to 0.13.0. | expand

Commit Message

Hilton Chain May 28, 2023, 8:11 a.m. UTC
* gnu/packages/textutils.scm (utfcpp): Update to 3.2.3.
[arguments]<#:phases>: Add phase 'unpack-ftest.
---
 gnu/packages/textutils.scm | 20 +++++++-------------
 1 file changed, 7 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index da0f2023a9..a49167c991 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -699,7 +699,7 @@  (define ftest-for-utfcpp
 (define-public utfcpp
   (package
     (name "utfcpp")
-    (version "2.3.5")
+    (version "3.2.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -708,20 +708,14 @@  (define-public utfcpp
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1gr98d826z6wa58r1s5i7rz7q2x3r31v7zj0pjjlrc7gfxwklr4s"))))
+                "00hzh39iddbc6nxg13813qd6d55g2kccwjf5dr96wykfhway9wbr"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:out-of-source? #f
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'install              ; no install target
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (include (string-append out "/include"))
-                    (doc (string-append out "/share/doc/" ,name)))
-               (copy-recursively "source" include)
-               (install-file "README.md" doc)
-               #t))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'unpack-ftest
+                 (lambda* (#:key native-inputs #:allow-other-keys)
+                   (copy-recursively #$ftest-for-utfcpp "extern/ftest"))))))
     (home-page "https://github.com/nemtrif/utfcpp")
     (synopsis "Portable C++ library for handling UTF-8")
     (description "UTF8-CPP is a C++ library for handling UTF-8 encoded text