diff mbox series

[bug#63700] gnu: jc: Update to 1.23.2.

Message ID 20230524180948.335339-1-code@greghogan.com
State New
Headers show
Series [bug#63700] gnu: jc: Update to 1.23.2. | expand

Commit Message

Greg Hogan May 24, 2023, 6:09 p.m. UTC
* gnu/packages/admin.scm (jc): Update to 1.23.2.
[build-system]: Change to PYPROJECT-BUILD-SYSTEM.
[native-inputs]: Add python-pytest.
---
 gnu/packages/admin.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Comments

宋文武 May 26, 2023, 1:07 p.m. UTC | #1
Greg Hogan <code@greghogan.com> writes:

> * gnu/packages/admin.scm (jc): Update to 1.23.2.

Pushed now, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8541775eb4..46f3612a05 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -85,6 +85,7 @@  (define-module (gnu packages admin)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix build-system qt)
   #:use-module (guix build-system ruby)
   #:use-module (guix build-system trivial)
@@ -4822,7 +4823,7 @@  (define-public pam-mount
 (define-public jc
   (package
     (name "jc")
-    (version "1.19.0")
+    (version "1.23.2")
     (source
      (origin
        ;; The PyPI tarball lacks the test suite.
@@ -4832,8 +4833,8 @@  (define-public jc
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "021zk0y8kb6v3qf3hwfg8qjzzmrca039nz3fjywiy2njmbhr8hyi"))))
-    (build-system python-build-system)
+        (base32 "17g2q0h3jwzfm80ldl8inpyh5y0qzzmgvyg10gkk1rp8i34wfgly"))))
+    (build-system pyproject-build-system)
     (arguments
      (list #:phases
            #~(modify-phases %standard-phases
@@ -4842,6 +4843,7 @@  (define-public jc
                  (lambda _
                    (substitute* (find-files "tests" "^test.*\\.py$")
                      (("America/Los_Angeles") "PST8PDT")))))))
+    (native-inputs (list python-pytest))
     (propagated-inputs
      (list python-pygments python-ruamel.yaml python-xmltodict))
     (home-page "https://github.com/kellyjonbrazil/jc")