diff mbox series

[bug#63609,1/4] gnu: Add ocaml-parmap.

Message ID 20230521113417.76939-1-jean@foundationdevices.com
State New
Headers show
Series gnu: Add coccinelle. | expand

Commit Message

Jean-Pierre De Jesus DIAZ May 21, 2023, 11:34 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-parmap): New variable.

Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com>
---
 gnu/packages/ocaml.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

Simon Tournier May 22, 2023, 5 p.m. UTC | #1
Hi,

Thanks for your patch.

On dim., 21 mai 2023 at 13:34, Jean-Pierre De Jesus DIAZ via Guix-patches via <guix-patches@gnu.org> wrote:

> +;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>

Just to be sure, the copyright is hold by that company named Foundation
Devices, Inc. and not by one person.  Right?


Cheers,
simon
Jean-Pierre De Jesus DIAZ May 23, 2023, 2:07 p.m. UTC | #2
Hi,

Yes Simon, that is correct. Sending again as I didn't reply to all.

Cheers,


On Mon, May 22, 2023 at 7:02 PM Simon Tournier <zimon.toutoune@gmail.com> wrote:
>
> Hi,
>
> Thanks for your patch.
>
> On dim., 21 mai 2023 at 13:34, Jean-Pierre De Jesus DIAZ via Guix-patches via <guix-patches@gnu.org> wrote:
>
> > +;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
>
> Just to be sure, the copyright is hold by that company named Foundation
> Devices, Inc. and not by one person.  Right?
>
>
> Cheers,
> simon
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f0b8f9e912..08036ba401 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -28,6 +28,7 @@ 
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
 ;;; Copyright © 2023 Csepp <raingloom@riseup.net>
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2698,6 +2699,42 @@  (define-public ocaml-ppx-tools
 syntactic tools.")
     (license license:expat)))
 
+(define-public ocaml-parmap
+  (package
+    (name "ocaml-parmap")
+    (version "1.2.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rdicosmo/parmap")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0x5gnfap9f7kmgh8j725vxlbkvlplwzbpn8jdx2ywfa3dd6bn6xl"))))
+    (build-system dune-build-system)
+    (propagated-inputs
+     (list ocaml-odoc))
+    (home-page "https://github.com/rdicosmo/parmap")
+    (synopsis "Parallel map and fold primtives for OCaml")
+    (description
+     "Library to perform parallel fold or map taking advantage of multiple
+core architectures for OCaml programs.  Drop-in replacement for these
+@code{List} operations are provided:
+
+@itemize
+@item @code{List.map} -> @code{parmap}
+@item @code{List.map} -> @code{parfold}
+@item @code{List.mapfold} -> @code{parmapfold}
+@end itemize
+
+Also it allows specifying the number of cores to use with the optional
+parameter @code{ncores}.")
+    (license (list license:lgpl2.0
+                   (license:fsdg-compatible "file://LICENSE"
+                                            "See LICENSE file for details")))))
+
 (define-public ocaml-react
   (package
     (name "ocaml-react")