diff mbox series

[bug#63623,3/4] gnu: python-pint: Fix build.

Message ID 20230521053726.1507055-3-monego@posteo.net
State New
Headers show
Series Add MetPy. | expand

Commit Message

Vinicius Monego May 21, 2023, 5:37 a.m. UTC
* gnu/packages/python-xyz (python-pint)[build-system]: Switch to
pyproject-build-system.
[arguments]: Skip a failing test.
[native-inputs]: Sort alphabetically and add python-importlib-metadata.
---
 gnu/packages/python-xyz.scm | 14 +++++++++-----
 1 file changed, 9 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3788cefda2..3dba197a94 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1066,17 +1066,21 @@  (define-public python-pint
               (sha256
                (base32
                 "0rv0cbala7ibjbaf6kkcn0mdhqdbajnvlcw0f15gwzfwg10g0z1q"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
+    (arguments
+     ;; This single test tries to write to $HOME/.cache/pint.
+     (list #:test-flags #~'("-k" "not test_auto")))
     (native-inputs
-     (list python-pytest                ;for pytest-subtests
+     (list python-dask
+           python-distributed
+           python-importlib-metadata
+           python-pytest                ;for pytest-subtests
            python-pytest-cov
            python-pytest-mpl
            python-pytest-subtests
            python-setuptools-scm
            python-sparse
-           python-dask
-           python-xarray
-           python-distributed))
+           python-xarray))
     (home-page "https://github.com/hgrecco/pint")
     (synopsis "Physical quantities module")
     (description