diff mbox series

[bug#63584] gnu: d-feet: Fix the build error when using Meson 1.1.0.

Message ID 20230519123528.5119-1-all_but_last@163.com
State New
Headers show
Series [bug#63584] gnu: d-feet: Fix the build error when using Meson 1.1.0. | expand

Commit Message

Zhu Zihao May 19, 2023, 12:35 p.m. UTC
Fix the build error:

data/meson.build:15:0: ERROR: Function does not take positional arguments.
data/meson.build:27:0: ERROR: Function does not take positional arguments.

* gnu/packages/patches/d-feet-drop-unused-meson-argument.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add new entry.
* gnu/packages/gnome.scm (d-feet)[source]: Apply the patch.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/gnome.scm                        | 19 +++++-----
 .../d-feet-drop-unused-meson-argument.patch   | 36 +++++++++++++++++++
 3 files changed, 48 insertions(+), 8 deletions(-)
 create mode 100644 gnu/packages/patches/d-feet-drop-unused-meson-argument.patch

Comments

Zhu Zihao May 29, 2023, 3:02 p.m. UTC | #1
ping.

And this should close https://issues.guix.gnu.org/63270
Liliana Marie Prikler May 29, 2023, 7:34 p.m. UTC | #2
Am Montag, dem 29.05.2023 um 23:02 +0800 schrieb Zhu Zihao:
> ping.
> 
> And this should close https://issues.guix.gnu.org/63270
Note that you mentioned the wrong thread there, but anyway: the patch
mixes functional and non-functional changes, which I think should be
kept separate.  If I count my columns correctly, you can do with -1/+2
on gnu/packages/gnome.scm

Cheers
Zhu Zihao May 31, 2023, 4:05 a.m. UTC | #3
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Note that you mentioned the wrong thread there, but anyway: the patch
> mixes functional and non-functional changes, which I think should be
> kept separate.  If I count my columns correctly, you can do with -1/+2
> on gnu/packages/gnome.scm

Do you mean I should not change the indentation here?
Liliana Marie Prikler May 31, 2023, 4:24 a.m. UTC | #4
Am Mittwoch, dem 31.05.2023 um 12:05 +0800 schrieb Zhu Zihao:
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > Note that you mentioned the wrong thread there, but anyway: the
> > patch mixes functional and non-functional changes, which I think
> > should be kept separate.  If I count my columns correctly, you can
> > do with -1/+2 on gnu/packages/gnome.scm
> 
> Do you mean I should not change the indentation here?
Exactly.  If you wish to apply `guix style' or similar formatting, I
recommend a follow-up commit.

Cheers
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index d31b40f3bf..f44192b28f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1033,6 +1033,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/cvs-CVE-2017-12836.patch		\
   %D%/packages/patches/c++-gsl-find-system-gtest.patch		\
   %D%/packages/patches/c++-gsl-move-array-bounds-tests.patch	\
+  %D%/packages/patches/d-feet-drop-unused-meson-argument.patch	\
   %D%/packages/patches/date-output-pkg-config-files.patch	\
   %D%/packages/patches/datefudge-gettimeofday.patch		\
   %D%/packages/patches/dbacl-include-locale.h.patch		\
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 754bb668ba..5a0259d5ab 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -74,6 +74,7 @@ 
 ;;; Copyright © 2022 Alexandros Theodotou <alex@zrythm.org>
 ;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
 ;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
+;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7190,14 +7191,16 @@  (define-public d-feet
   (package
     (name "d-feet")
     (version "0.3.16")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/" name "/"
-                                  (version-major+minor version) "/"
-                                  name "-" version ".tar.xz"))
-              (sha256
-               (base32
-                "1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://gnome/sources/" name "/"
+                           (version-major+minor version) "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))
+       (patches (search-patches "d-feet-drop-unused-meson-argument.patch"))))
     (build-system meson-build-system)
     (arguments
      (list
diff --git a/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch b/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch
new file mode 100644
index 0000000000..5d728d7d60
--- /dev/null
+++ b/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch
@@ -0,0 +1,36 @@ 
+From 05465d486afdba116dbc22fc22c1e6573aea4f22 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 24 Jan 2022 12:11:57 +0000
+Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/meson.build:15:0: ERROR: Function does not take positional arguments.
+data/meson.build:27:0: ERROR: Function does not take positional arguments.
+---
+ data/meson.build | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index 026bd80..3b03b94 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -13,7 +13,6 @@ desktop_in = configure_file(
+ )
+ 
+ i18n.merge_file(
+-  desktop,
+   type: 'desktop',
+   input: desktop_in,
+   output: '@BASENAME@',
+@@ -25,7 +24,6 @@ i18n.merge_file(
+ appdata = df_namespace + '.appdata.xml'
+ 
+ i18n.merge_file(
+-  appdata,
+   input: appdata + '.in',
+   output: '@BASENAME@',
+   po_dir: po_dir,
+-- 
+GitLab
+