diff mbox series

[bug#63576,v1,1/4] gnu: Add aarch64-none-elf-binutils.

Message ID 20230518182814.15881-1-GNUtoo@cyberdimension.org
State New
Headers show
Series Add aarch64-none-elf-gcc-toolchain. | expand

Commit Message

Denis 'GNUtoo' Carikli May 18, 2023, 6:28 p.m. UTC
* gnu/packages/aarch64-none-elf-toolchain.scm (aarch64-none-elf-binutils): New
  variable.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add
  %D%/packages/aarch64-none-elf-toolchain.scm.
---
 gnu/local.mk                                |  1 +
 gnu/packages/aarch64-none-elf-toolchain.scm | 26 +++++++++++++++++++++
 2 files changed, 27 insertions(+)
 create mode 100644 gnu/packages/aarch64-none-elf-toolchain.scm
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 42514ded8e..9f914580a4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -106,6 +106,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/home/services/xdg.scm			\
   %D%/image.scm					\
   %D%/packages.scm				\
+  %D%/packages/aarch64-none-elf-toolchain.scm	\
   %D%/packages/abduco.scm			\
   %D%/packages/abiword.scm			\
   %D%/packages/accessibility.scm		\
diff --git a/gnu/packages/aarch64-none-elf-toolchain.scm b/gnu/packages/aarch64-none-elf-toolchain.scm
new file mode 100644
index 0000000000..14569036ce
--- /dev/null
+++ b/gnu/packages/aarch64-none-elf-toolchain.scm
@@ -0,0 +1,26 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages aarch64-none-elf-toolchain)
+  #:use-module (guix packages)
+  #:use-module (gnu packages cross-base))
+
+(define-public aarch64-none-elf-binutils
+  (package
+    (inherit (cross-binutils "aarch64-none-elf"))
+    (name "aarch64-none-elf-binutils")))