diff mbox series

[bug#63574,v1] gnu: cpp-mustache: Update to 5.0 to fix build.

Message ID 20230518155118.4622-1-GNUtoo@cyberdimension.org
State New
Headers show
Series [bug#63574,v1] gnu: cpp-mustache: Update to 5.0 to fix build. | expand

Commit Message

Denis 'GNUtoo' Carikli May 18, 2023, 3:51 p.m. UTC
* gnu/packages/cpp.scm (cpp-mustache): Update to 5.0.
---
 gnu/packages/cpp.scm | 17 ++++++++++++-----
 1 file changed, 12 insertions(+), 5 deletions(-)


base-commit: 5b700945fb0b33eec410de8979cae2fbf0d4f118
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 237e232078..233f4b79d9 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -35,6 +35,7 @@ 
 ;;; Copyright © 2023 Sughosha <Sughosha@proton.me>
 ;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2023 Liliana Marie Prikler <liliana.prikler@gmail.com>
+;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2115,29 +2116,35 @@  (define-public gulrak-filesystem
 (define-public cpp-mustache
   (package
     (name "cpp-mustache")
-    (version "4.1")
+    (version "5.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/kainjow/Mustache")
-                    (commit (string-append "v" version))))
+                    (commit "4ed8c0b5a2a43d59394bd6900dc04e738dbf8c02")))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0r9rbk6v1wpld2ismfsk2lkhbyv3dkf0p03hkjivbj05qkfhvlbb"))))
+                "0qwrg35gby851viwd6dgrc346712701a0gll8a0m4xs8invxavrh"))))
     (build-system cmake-build-system)
     (arguments
-     (list #:phases
+     (list #:configure-flags
+           #~(list
+              (string-append "-DCMAKE_CXX_FLAGS=-I"
+                             #$(this-package-native-input "catch2")
+                             "/include/catch2/"))
+           #:phases
            #~(modify-phases %standard-phases
                (replace 'check
                  (lambda* (#:key tests? #:allow-other-keys)
                    (when tests?
-                     (invoke "./mustache"))))
+                     (invoke "./tests/mustache-unit-tests"))))
                (replace 'install
                  (lambda* (#:key outputs #:allow-other-keys)
                    (install-file "../source/mustache.hpp"
                                  (string-append (assoc-ref outputs "out")
                                                 "/include")))))))
+    (native-inputs (list catch2))
     (home-page "https://github.com/kainjow/Mustache")
     (synopsis "Mustache text templates for modern C++")
     (description "@code{cpp-mustache} is a Mustache implementation for C++ 11