diff mbox series

[bug#61823] gnu: Add tmux-plugin-continuum.

Message ID 20230517122405.13299-1-eu@euandre.org
State New
Headers show
Series [bug#61823] gnu: Add tmux-plugin-continuum. | expand

Commit Message

EuAndreh May 17, 2023, 12:24 p.m. UTC
* gnu/packages/tmux.scm (tmux-plugin-continuum): New variable.
---

Notes:
    Fixed the spelling XD

 gnu/packages/tmux.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)


base-commit: c8e599b9391f789a8a3e2183fc8f0c2a5061ceb0

Comments

EuAndreh May 17, 2023, 12:28 p.m. UTC | #1
This version was rebased with master.
Ludovic Courtès June 8, 2023, 9:43 p.m. UTC | #2
Hi,

EuAndreh <eu@euandre.org> skribis:

> * gnu/packages/tmux.scm (tmux-plugin-continuum): New variable.

Finally applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 67ce18fea1..7ed3c6aef3 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -317,3 +317,44 @@  (define-public tmux-plugin-resurrect
 @end itemize")
       (home-page "https://github.com/tmux-plugins/tmux-resurrect/")
       (license license:expat))))
+
+(define-public tmux-plugin-continuum
+  (let ((commit "3e4bc35da41f956c873aea716c97555bf1afce5d")
+        (revision "0"))
+    (package
+      (name "tmux-plugin-continuum")
+      (version (git-version "0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/tmux-plugins/tmux-continuum/")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1py8qfs2f93hkxhk039m813bjgcs5k54si662gx05g3czqy06pb7"))))
+      (build-system trivial-build-system)
+      (arguments
+       `(#:modules ((guix build utils))
+         #:builder (begin
+                     (use-modules (guix build utils))
+                     (let ((out (string-append %output
+                                 "/share/tmux-plugins/continuum/")))
+                       (mkdir-p out)
+                       (copy-recursively (assoc-ref %build-inputs "source")
+                                         out)))))
+      (synopsis "Continuous saving of tmux environment")
+      (description
+       "Features:
+
+@itemize
+@item continuous saving of tmux environment
+@item automatic tmux start when computer/server is turned on
+@item automatic restore when tmux is started
+@end itemize
+
+Together, these features enable uninterrupted tmux usage.  No matter the
+computer or server restarts, if the machine is on, tmux will be there how you
+left it off the last time it was used.")
+      (home-page "https://github.com/tmux-plugins/tmux-continuum/")
+      (license license:expat))))