diff mbox series

[bug#63448,v2,2/2] gnu: Add python-mgatk.

Message ID 20230512103359.4111-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series None | expand

Commit Message

Mădălin Ionel Patrașcu May 12, 2023, 10:33 a.m. UTC
* gnu/packages/bioinformatics.scm (python-mgatk): New variable.
---
 gnu/packages/bioinformatics.scm | 54 +++++++++++++++++++++++++++++++++
 1 file changed, 54 insertions(+)


base-commit: d07342b16612cfdffad6a7b3504b74e0d95d551f
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index afca5ab93b..86e54ad5f5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12628,6 +12628,60 @@  (define-public python-biothings-client
 API services.")
     (license license:bsd-3)))
 
+(define-public python-mgatk
+  (let ((commit "2633903acb1fb406bb58c787f320c3641f446ee7")
+        (revision "0"))
+    (package
+      (name "python-mgatk")
+      (version "0.6.7")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/caleblareau/mgatk")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         ;(method url-fetch)
+         ;(uri (pypi-uri "mgatk" version))
+         (sha256
+          (base32 "19iklfv1brwsfg1l5lrs3z8m343nskkn1998c1fs7fdn0lgrki2p"))))
+      (build-system pyproject-build-system)
+      (arguments
+       (list
+        #:phases
+        #~(modify-phases %standard-phases
+          ;; The md5 module has beed deprecated since Python 2.5
+          (add-after 'unpack 'make-python3-compatible
+             (lambda* _
+               (substitute* "tests/test_cli.py"
+                 (("import md5") ""))))
+           (replace 'check
+             (lambda* (#:key tests? #:allow-other-keys)
+               (when tests?
+                 (invoke "pytest" "-vv" "-k" "not file_checksums_equal")))))))
+      (propagated-inputs
+       (list python-biopython
+             python-click
+             python-numpy
+             python-optparse-pretty
+             python-pandas
+             python-pysam
+             python-regex
+             python-ruamel.yaml
+             snakemake))
+      (native-inputs
+       (list python-minimal
+             python-pytest))
+      (home-page "https://github.com/caleblareau/mgatk")
+      (synopsis "Mitochondrial genome analysis toolkit.")
+      (description "This package is a python-based command line interface for
+processing .bam files with mitochondrial reads and generating high-quality
+heteroplasmy estimation from sequencing data.  The mgatk package places a
+special emphasis on mitochondrial genotypes generated from single-cell genomics
+data, primarily @acronym{mtscATAC-seq, mitochondrial single-cell ATAC-sequence},
+but is generally applicable across other assays.")
+      (license license:expat))))
+
 (define-public python-multivelo
   (package
     (name "python-multivelo")