diff mbox series

[bug#63454] gnu: Add tmux-plugin-mem-cpu-load.

Message ID 20230511214715.1106253-1-code@greghogan.com
State New
Headers show
Series [bug#63454] gnu: Add tmux-plugin-mem-cpu-load. | expand

Commit Message

Greg Hogan May 11, 2023, 9:47 p.m. UTC
* gnu/packages/tmux.scm (tmux-plugin-mem-cpu-load): New variable.
---
 gnu/packages/tmux.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index ec6bf78559..a0c877b795 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -30,6 +30,7 @@  (define-module (gnu packages tmux)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (guix build-system python)
@@ -357,3 +358,30 @@  (define-public tmux-plugin-continuum
 left it off the last time it was used.")
       (home-page "https://github.com/tmux-plugins/tmux-continuum/")
       (license license:expat))))
+
+(define-public tmux-plugin-mem-cpu-load
+  (package
+    (name "tmux-plugin-mem-cpu-load")
+    (version "3.7.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/thewtex/tmux-mem-cpu-load")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "03bax7g9jlsci44ccs50drh617ya3fzvlplwyvxfyb7mgmh85r72"))
+              (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (synopsis "CPU, RAM, and load monitor for use with tmux")
+    (description "A simple, lightweight program for system monitoring in the
+status line of tmux.
+
+The memory monitor displays the used and available memory.
+
+The CPU usage monitor outputs a percent CPU usage over all processors. It also
+displays a textual bar graph of the current percent usage.
+
+The system load average is also displayed.")
+    (home-page "https://github.com/thewtex/tmux-mem-cpu-load")
+    (license license:asl2.0)))