diff mbox series

[bug#63421,v1] gnu: ghc-tasty: Fix build for i686

Message ID 20230510171829.6497-1-GNUtoo@cyberdimension.org
State New
Headers show
Series [bug#63421,v1] gnu: ghc-tasty: Fix build for i686 | expand

Commit Message

Denis 'GNUtoo' Carikli May 10, 2023, 5:18 p.m. UTC
Without that fix we have:
  Configuring tasty-1.4.3...
  Setup.hs: Encountered missing or private dependencies:
  unbounded-delays >=0.1

* gnu/packages/haskell-check.scm(ghc-tasty)[inputs]: Add ghc-unbounded-delays

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
 gnu/packages/haskell-check.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)


base-commit: e0c35d1578c10a8fe27c8372f3a8bb5dd88b01b8

Comments

Lars-Dominik Braun May 13, 2023, 8:23 a.m. UTC | #1
Hi,

> -    (inputs (list ghc-tagged ghc-optparse-applicative ghc-ansi-terminal))
> +    (inputs (list ghc-unbounded-delays ghc-tagged ghc-optparse-applicative
> +                  ghc-ansi-terminal))

that’s a pretty big rebuild (~1500 packages). I’ve added this
conditionally in commit cf89a215cec346bc4d6622cbe353c058452b29b2.

Cheers,
Lars
Denis 'GNUtoo' Carikli May 15, 2023, 1:57 p.m. UTC | #2
On Sat, 13 May 2023 10:23:38 +0200
Lars-Dominik Braun <lars@6xq.net> wrote:

> Hi,
Hi,

> > -    (inputs (list ghc-tagged ghc-optparse-applicative
> > ghc-ansi-terminal))
> > +    (inputs (list ghc-unbounded-delays ghc-tagged
> > ghc-optparse-applicative
> > +                  ghc-ansi-terminal))
> 
> that’s a pretty big rebuild (~1500 packages). I’ve added this
> conditionally in commit cf89a215cec346bc4d6622cbe353c058452b29b2.
Thanks a lot and sorry for forgetting to check about the number of
rebuilds.

Denis.
diff mbox series

Patch

diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 23727fc0b8..95c9521796 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -148,7 +148,8 @@  (define-public ghc-tasty
                 "006bf4gyc30i2gvb17hj1mzrh1kwnwf7l050x3f72wi6c2axl87l"))))
     (build-system haskell-build-system)
     (properties '((upstream-name . "tasty")))
-    (inputs (list ghc-tagged ghc-optparse-applicative ghc-ansi-terminal))
+    (inputs (list ghc-unbounded-delays ghc-tagged ghc-optparse-applicative
+                  ghc-ansi-terminal))
     (home-page "https://github.com/UnkindPartition/tasty")
     (synopsis "Modern and extensible testing framework")
     (description