diff mbox series

[bug#63420,v1,2/4] gnu: btrfs-progs: Use new style inputs and gexps.

Message ID 20230510163925.3071-2-GNUtoo@cyberdimension.org
State New
Headers show
Series Guix patches for btrfs-progs | expand

Commit Message

Denis 'GNUtoo' Carikli May 10, 2023, 4:39 p.m. UTC
* gnu/packages/linux.scm (btrfs-progs)[arguments]: Use new style and gexps.
  [inputs]: Use new style.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
 gnu/packages/linux.scm | 100 ++++++++++++++++++++---------------------
 1 file changed, 49 insertions(+), 51 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c2449f0b45..a71100baab 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5892,60 +5892,58 @@  (define-public btrfs-progs
     (build-system gnu-build-system)
     (outputs '("out" "static")) ;static versions of the binaries in "out"
     (arguments
-     '(#:configure-flags
-       ;; The ‘Python support’ was never actually installed by previous
-       ;; versions of this package, but did prevent cross-compilation.
-       (list "--disable-python")
-       #:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'patch-makefile
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (substitute* "Makefile"
-                        (("\\$\\(DESTDIR\\)\\$\\(udevruledir\\)")
-                         (string-append (assoc-ref outputs "out")
-                                        "/lib/udev/rules.d")))))
-                  (add-after 'build 'build-static
-                    (lambda _
-                      (invoke "make" "static")))
-                  (add-after 'install 'install-bash-completion
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (let* ((out (assoc-ref outputs "out"))
-                             (bashcomp (string-append out
-                                        "/etc/bash_completion.d")))
-                        (mkdir-p bashcomp)
-                        (copy-file "btrfs-completion"
-                                   (string-append bashcomp "/btrfs")))))
-                  (add-after 'install 'install-static
-                    (let ((staticbin (string-append (assoc-ref %outputs
-                                                               "static")
-                                                    "/bin")))
-                      (lambda _
-                        (invoke "make"
-                                (string-append "bindir=" staticbin)
-                                "install-static")))))
+     (list
+      #:configure-flags
+      ;; The ‘Python support’ was never actually installed by previous
+      ;; versions of this package, but did prevent cross-compilation.
+      #~(list "--disable-python")
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'patch-makefile
+                     (lambda* (#:key outputs #:allow-other-keys)
+                       (substitute* "Makefile"
+                         (("\\$\\(DESTDIR\\)\\$\\(udevruledir\\)")
+                          (string-append (assoc-ref outputs "out")
+                                         "/lib/udev/rules.d")))))
+                   (add-after 'build 'build-static
+                     (lambda _
+                       (invoke "make" "static")))
+                   (add-after 'install 'install-bash-completion
+                     (lambda* (#:key outputs #:allow-other-keys)
+                       (let* ((out (assoc-ref outputs "out"))
+                              (bashcomp (string-append out
+                                                       "/etc/bash_completion.d")))
+                         (mkdir-p bashcomp)
+                         (copy-file "btrfs-completion"
+                                    (string-append bashcomp "/btrfs")))))
+                   (add-after 'install 'install-static
+                     (let ((staticbin (string-append (assoc-ref %outputs
+                                                                "static")
+                                                     "/bin")))
+                       (lambda _
+                         (invoke "make"
+                                 (string-append "bindir=" staticbin)
+                                 "install-static")))))
        #:tests? #f ;XXX: require the 'btrfs' kernel module.
        #:test-target "test"
        #:parallel-tests? #f)) ;tests fail when run in parallel
-    (inputs `(("e2fsprogs" ,e2fsprogs)
-               ;for btrfs-convert
-              ("eudev" ,eudev)
-              ("lzo" ,lzo)
-              ("util-linux:lib" ,util-linux "lib") ;for libblkid and libuuid
-              ("util-linux:static" ,util-linux "static") ;ditto
-              ("zlib" ,zlib)
-              ("zlib:static" ,zlib "static")
-              ("zstd" ,zstd "lib")
-              ("zstd:static" ,zstd "static")))
-    (native-inputs `(("pkg-config" ,pkg-config)
-                     ;; For building documentation.
-                     ("python-sphinx" ,python-sphinx)
-                     ;; For tests.
-                     ("acl" ,acl)
-                     ("dmsetup" ,lvm2)
-                     ("grep" ,grep) ;need Perl regexp support
-                     ("libaio" ,libaio)
-                     ("liburing" ,liburing)
-                     ("util-linux" ,util-linux) ;for fallocate
-                     ("which" ,which)))
+    (inputs (list e2fsprogs               ;; For btrfs-convert.
+                  eudev
+                  lzo
+                  `(,util-linux "lib")    ;; For libblkid and libuuid.
+                  `(,util-linux "static") ;; Ditto.
+                  zlib
+                  `(,zlib "static")
+                  `(,zstd "lib")
+                  `(,zstd "static")))
+    (native-inputs (list pkg-config
+                         python-sphinx ;; For building documentation.
+                         acl           ;; For tests.
+                         lvm2          ;; For dmsetup.
+                         grep          ;; Need Perl regexp support.
+                         libaio
+                         liburing
+                         util-linux    ;; For fallocate.
+                         which))
     (home-page "https://btrfs.wiki.kernel.org/index.php/Main_Page")
     (synopsis "Create and manage btrfs copy-on-write file systems")
     (description