diff mbox series

[bug#63295] Update csvkit to 1.1.1

Message ID 20230506172704.3184033d@ens-lyon.fr
State New
Headers show
Series [bug#63295] Update csvkit to 1.1.1 | expand

Commit Message

Alice BRENON May 6, 2023, 3:27 p.m. UTC
Thanks for your vigilance and sorry for the duplicate. Following our
discussion I'll leave it open for now, hoping one of them will be
reviewed and accepted.

I'll also follow the advice of the linter (actually I had first gone for a
substitute* to fix the errors in the tests it was the linter which suggested I
updated the packages, making me completely rewrite my patch and taking some time
to check whether the dependencies where still needed and then I forgot to put a pair of
parenthesis back to the line where they belonged — that, and to re-run the
linter after having reworked on the patch that much, that is) and here is a
hopefully cleaner version of my patch.

Le Fri, 5 May 2023 08:41:31 -0400,
Greg Hogan <code@greghogan.com> a écrit :

> On Fri, May 5, 2023 at 6:27 AM Alice BRENON
> <alice.brenon@ens-lyon.fr> wrote:
> >
> > Hello guix,
> >
> > I use csvkit and noticed it broke after the upgrade to python 3.10  
> 
> #62418 from March 24 also fixes csvkit with updated dependencies.

Comments

Greg Hogan May 11, 2023, 10:08 p.m. UTC | #1
On Sat, May 6, 2023 at 11:27 AM Alice BRENON <alice.brenon@ens-lyon.fr> wrote:
>
> Thanks for your vigilance and sorry for the duplicate. Following our
> discussion I'll leave it open for now, hoping one of them will be
> reviewed and accepted.
>
> I'll also follow the advice of the linter (actually I had first gone for a
> substitute* to fix the errors in the tests it was the linter which suggested I
> updated the packages, making me completely rewrite my patch and taking some time
> to check whether the dependencies where still needed and then I forgot to put a pair of
> parenthesis back to the line where they belonged — that, and to re-run the
> linter after having reworked on the patch that much, that is) and here is a
> hopefully cleaner version of my patch.

The patch should be divided with each package update in a separate
patch (a large number of small, similar updates can be made in a
single patch).

Your update to python-agate includes glibc-locales (a 932 MiB package)
whereas mine added python-agate-locales as a new package. Yours has
(as noted) additional changes to the inputs.

My patchset updates python-agate-sql. I don't recall why, but it must
have fixed a breaking build. The only dependent package is csvkit.
diff mbox series

Patch

From 93f3fb1a88ac38bb66dbf39f074fbc21ebe25f77 Mon Sep 17 00:00:00 2001
Message-Id: <93f3fb1a88ac38bb66dbf39f074fbc21ebe25f77.1683386106.git.alice.brenon@ens-lyon.fr>
From: Alice BRENON <alice.brenon@ens-lyon.fr>
Date: Fri, 5 May 2023 12:03:58 +0200
Subject: [PATCH] gnu: csvkit: Update to 1.1.1.

Update package and its dependencies, getting rid of collections errors
due to python 3.10 in the process and converting inputs to new style.

* gnu/packages/wireservice.scm (csvkit): Update to 1.1.1
* gnu/packages/wireservice.scm (python-leather): Update to 0.3.4
* gnu/packages/wireservice.scm (python-agate): Update to 1.7.1
* gnu/packages/wireservice.scm (python-agate-dbf): Update to 0.2.2
---
 gnu/packages/wireservice.scm | 68 ++++++++++++++++++++----------------
 1 file changed, 37 insertions(+), 31 deletions(-)

diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index d315bc2d74..258671fc30 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -26,6 +26,7 @@  (define-module (gnu packages wireservice)
   #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (gnu packages)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages check)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages python-web)
@@ -65,7 +66,7 @@  (define-syntax-rule (wireservice-package extra-fields ...)
 (define-public python-leather
   (wireservice-package
    (name "python-leather")
-   (version "0.3.3")
+   (version "0.3.4")
    (source (origin
              (method git-fetch)
              (uri (git-reference
@@ -74,15 +75,15 @@  (define-public python-leather
              (file-name (git-file-name name version))
              (sha256
               (base32
-               "1ck3dplni99sv4s117cbm07ydwwjsrxkhdy19rnk0iglia1d4s5i"))))
+               "00cg4cidl15q1xv2pmxdkia5brig7x0xy9hwf2mlf9cq39bpj1w6"))))
    (native-inputs
-    `(("python-nose" ,python-nose)
-      ("python-sphinx" ,python-sphinx)
-      ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
-      ("python-csselect" ,python-cssselect)
-      ("python-lxml" ,python-lxml)))
+    (list python-nose
+          python-sphinx
+          python-sphinx-rtd-theme
+          python-cssselect
+          python-lxml))
    (propagated-inputs
-    `(("python-six" ,python-six)))
+    (list python-six))
    (home-page "https://leather.rtfd.org")
    (synopsis "Python charting for 80% of humans")
    (description "Leather is a Python charting library for those who need
@@ -91,7 +92,7 @@  (define-public python-leather
 (define-public python-agate
   (wireservice-package
    (name "python-agate")
-   (version "1.6.1")
+   (version "1.7.1")
    (source (origin
              (method git-fetch)
              (uri (git-reference
@@ -100,21 +101,26 @@  (define-public python-agate
              (file-name (git-file-name name version))
              (sha256
               (base32
-               "077zj8xad8hsa3nqywvf7ircirmx3krxdipl8wr3dynv3l3khcpl"))))
+               "1wqyml7f70hr7zhgwvwqy4bdshlbcmp4jmyc5y12jyx10xp3sk7c"))))
    (native-inputs
-    `(("python-nose" ,python-nose)
-      ("python-sphinx" ,python-sphinx)
-      ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
-      ("python-csselect" ,python-cssselect)
-      ("python-lxml" ,python-lxml)))
+    (list glibc-locales
+          python-coverage
+          python-cssselect
+          python-lxml
+          python-nose
+          python-pyicu
+          python-pytest
+          python-pytest-cov
+          python-pytz
+          python-sphinx
+          python-sphinx-rtd-theme))
    (propagated-inputs
-    `(("python-babel" ,python-babel)
-      ("python-isodate" ,python-isodate)
-      ("python-leather" ,python-leather)
-      ("python-parsedatetime" ,python-parsedatetime)
-      ("python-pytimeparse" ,python-pytimeparse)
-      ("python-six" ,python-six)
-      ("python-slugify" ,python-slugify)))
+    (list python-babel
+          python-isodate
+          python-leather
+          python-parsedatetime
+          python-pytimeparse
+          python-slugify))
    (home-page "https://agate.rtfd.org")
    (synopsis "Data analysis library")
    (description "Agate is a Python data analysis library.  It is an
@@ -150,7 +156,7 @@  (define-public python-agate-sql
 (define-public python-agate-dbf
   (wireservice-package
    (name "python-agate-dbf")
-   (version "0.2.1")
+   (version "0.2.2")
    (source (origin
              (method git-fetch)
              (uri (git-reference
@@ -159,14 +165,14 @@  (define-public python-agate-dbf
              (file-name (git-file-name name version))
              (sha256
               (base32
-               "1y49fi6pmm7gzhajvqmfpcca2sqnwj24fqnsvzwk7r1hg2iaa2gi"))))
+               "03l3qlyw7588jhjjsiy15valqlzs8gjai8f74v18zv2za0zjqbzl"))))
    (native-inputs
-    `(("python-nose" ,python-nose)
-      ("python-sphinx" ,python-sphinx)
-      ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
+    (list python-nose
+          python-sphinx
+          python-sphinx-rtd-theme))
    (propagated-inputs
-    `(("python-agate" ,python-agate)
-      ("python-dbfread" ,python-dbfread)))
+    (list python-agate
+          python-dbfread))
    (home-page "https://agate-dbf.rtfd.org")
    (synopsis "Add read support for dbf files to agate")
    (description "@code{agatedbf} uses a monkey patching pattern to add read
@@ -202,13 +208,13 @@  (define-public python-agate-excel
 (define-public csvkit
   (package
     (name "csvkit")
-    (version "1.0.5")
+    (version "1.1.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "csvkit" version))
               (sha256
                (base32
-                "1ffmbzk4rxnl1yhqfl58v7kvl5m9cbvjm8v7xp4mvr00sgs91lvv"))))
+                "08wj0hlmbdmklar12cjzqp91vcxzwifsvmgasszas8kbiyvvgpdy"))))
     (build-system python-build-system)
     (native-inputs
      (list python-psycopg2 ; to test PostgreSQL support

base-commit: cf44fb964e6216b153ab898002f2f2ab889532ce
-- 
2.39.2