diff mbox series

[bug#63266] gnu: python-screed: Update to 1.1.2.

Message ID 20230504142817.25611-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#63266] gnu: python-screed: Update to 1.1.2. | expand

Commit Message

Mădălin Ionel Patrașcu May 4, 2023, 2:28 p.m. UTC
* gnu/packages/bioinformatics.scm (python-screed): Update to 1.1.2.
[native-inputs]: Remove the unnecessary dependencies.
[inputs]: Remove the section.
[build-system]: Change to pyproject.
---
 gnu/packages/bioinformatics.scm | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)


base-commit: fa685c87eaa9888a4278f39bb2b815673589dced

Comments

Ricardo Wurmus May 4, 2023, 5:34 p.m. UTC | #1
Applied, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 181e68b44b..75ea7b35d6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7628,19 +7628,17 @@  (define-public preseq
 (define-public python-screed
   (package
     (name "python-screed")
-    (version "1.0")
+    (version "1.1.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "screed" version))
        (sha256
-        (base32
-         "148vcb7w2wr6a4w6vs2bsxanbqibxfk490zbcbg4m61s8669zdjx"))))
-    (build-system python-build-system)
+        (base32 "0slva743xn93h4sl5zg2as4ricnnj5pp6nw9dm4qclk4i9xglkvk"))))
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-pytest python-pytest-cov python-pytest-runner))
-    (inputs
-     (list python-bz2file))
+     (list python-pytest-cov
+           python-pytest-runner))
     (home-page "https://github.com/dib-lab/screed/")
     (synopsis "Short read sequence database utilities")
     (description "Screed parses FASTA and FASTQ files and generates databases.