diff mbox series

[bug#63176,v3,5/8] gnu: python-pytest-httpx: Update to 0.22.0.

Message ID 20230502214542.24461-6-felgru@posteo.net
State New
Headers show
Series None | expand

Commit Message

Felix Gruber May 2, 2023, 9:45 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-httpx): Update to 0.22.0.
  [build-system]: Use pyproject-build-system.
  [arguments]: Remove custom 'check phase.
---
 gnu/packages/python-check.scm | 14 +++-----------
 1 file changed, 3 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f451a5e999..10731178e3 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2513,7 +2513,7 @@  (define-public python-pytest-parawtf
 (define-public python-pytest-httpx
   (package
     (name "python-pytest-httpx")
-    (version "0.21.0")
+    (version "0.22.0")
     (source
      (origin
        ;; pypi package doesn't include the tests
@@ -2523,16 +2523,8 @@  (define-public python-pytest-httpx
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "12mcy1f5d5cq3rqrqgi2ar0qvzw62ibys17hw6dsdfd0j2syck4r"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (setenv "PYTHONPATH" (getcwd))
-               (invoke "pytest" "-vv")))))))
+        (base32 "1ncpd74hmsz4sadvjg99fnfscxpgh3mc2siini0dhxzwgwdkk5i7"))))
+    (build-system pyproject-build-system)
     (propagated-inputs (list python-httpx))
     (native-inputs (list python-pytest python-pytest-asyncio))
     (home-page "https://colin-b.github.io/pytest_httpx/")