diff mbox series

[bug#63209] gnu: git-crypt: Fix build issues on openssl 3

Message ID 20230501161842.5622-1-sarg@sarg.org.ru
State New
Headers show
Series [bug#63209] gnu: git-crypt: Fix build issues on openssl 3 | expand

Commit Message

Sergey Trofimov May 1, 2023, 4:18 p.m. UTC
* gnu/packages/version-control.scm (git-crypt):
Add compilation flag to work around openssl 3 compatibility.
See https://github.com/AGWA/git-crypt/issues/232
---
 gnu/packages/version-control.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Giovanni Biscuolo May 1, 2023, 9:35 p.m. UTC | #1
Hello,

thank you for your patch: I applied it and it works.

This is also related to bug#63202

Sergey Trofimov <sarg@sarg.org.ru> writes:

> * gnu/packages/version-control.scm (git-crypt):
> Add compilation flag to work around openssl 3 compatibility.
> See https://github.com/AGWA/git-crypt/issues/232
> ---
>  gnu/packages/version-control.scm | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
> index c2ec490383..ba213bafa6 100644
> --- a/gnu/packages/version-control.scm
> +++ b/gnu/packages/version-control.scm
> @@ -936,6 +936,7 @@ (define-public git-crypt
>               #t))
>           (replace 'build
>             (lambda _
> +             (setenv "CXXFLAGS" "-DOPENSSL_API_COMPAT=0x30000000L")
>               (invoke "make" "ENABLE_MAN=yes")))
>           (replace 'install
>             (lambda* (#:key outputs #:allow-other-keys)
> -- 
> 2.39.2

Thanks, Gio'
Ludovic Courtès May 5, 2023, 10 p.m. UTC | #2
Hi,

Sergey Trofimov <sarg@sarg.org.ru> skribis:

> * gnu/packages/version-control.scm (git-crypt):
> Add compilation flag to work around openssl 3 compatibility.
> See https://github.com/AGWA/git-crypt/issues/232

Applied the patch, with these two lines as a comment in the code.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c2ec490383..ba213bafa6 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -936,6 +936,7 @@  (define-public git-crypt
              #t))
          (replace 'build
            (lambda _
+             (setenv "CXXFLAGS" "-DOPENSSL_API_COMPAT=0x30000000L")
              (invoke "make" "ENABLE_MAN=yes")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)