diff mbox series

[bug#63208] gnu: gstreamer: Depend on glib-next

Message ID 20230501161702.29513-1-atai@atai.org
State New
Headers show
Series [bug#63208] gnu: gstreamer: Depend on glib-next | expand

Commit Message

Andy Tai May 1, 2023, 4:17 p.m. UTC
* gnu/packages/gstreamer.scm: gstreamer: [arguments] (configure-flags): Add "--wrap-mode=nofallback" to ensure no subproject sources in repo are used
  [propagated-inputs]: Use glib-next
  [inputs]: Use glib-next

* gnu/packages/gstreamer.scm: gst-plugins-base:   [propagated-inputs]: Use glib-next
  [inputs]: Use glib-next

* gnu/packages/gstreamer.scm: gst-plugins-bad:   [propagated-inputs]: Use glib-next. Add dav1d
  [inputs]: Use glib-next

* gnu/packages/gstreamer.scm: gst-plugins-ugly:   [propagated-inputs]: Use glib-next
  [inputs]: Use glib-next

* gnu/packages/gstreamer.scm: gst-editing-services   [propagated-inputs]: Use glib-next
  [inputs]: Use glib-next
---
 gnu/packages/gstreamer.scm | 26 ++++++++++++++------------
 1 file changed, 14 insertions(+), 12 deletions(-)


base-commit: 23552fb2fbcb78757e8b563de9466831f6386105
prerequisite-patch-id: 3805e062116fd14a78ca03847b237e75977c6d8d
prerequisite-patch-id: 9967fd9b0de5c36d810ca5c346e49762dfd3dad8
prerequisite-patch-id: f5feb08c9249508d22e0debbe47222324e9f354e

Comments

Liliana Marie Prikler May 1, 2023, 5:27 p.m. UTC | #1
Am Montag, dem 01.05.2023 um 09:17 -0700 schrieb Andy Tai:
> * gnu/packages/gstreamer.scm: gstreamer: [arguments] (configure-
> flags): Add "--wrap-mode=nofallback" to ensure no subproject sources
> in repo are used
>   [propagated-inputs]: Use glib-next
>   [inputs]: Use glib-next
We prefer not to bundle things, tyvm.

> * gnu/packages/gstreamer.scm: gst-plugins-base:   [propagated-
> inputs]: Use glib-next
>   [inputs]: Use glib-next
> 
> * gnu/packages/gstreamer.scm: gst-plugins-bad:   [propagated-inputs]:
> Use glib-next. Add dav1d
>   [inputs]: Use glib-next
> 
> * gnu/packages/gstreamer.scm: gst-plugins-ugly:   [propagated-
> inputs]: Use glib-next
>   [inputs]: Use glib-next
> 
> * gnu/packages/gstreamer.scm: gst-editing-services   [propagated-
> inputs]: Use glib-next
>   [inputs]: Use glib-next
> ---
Is there a *good* reason to do this now?  Note that gnome-team is
working on getting glib 2.76 everywhere, including GStreamer.

Cheers
Andy Tai May 1, 2023, 6:50 p.m. UTC | #2
Hi, I will revise the patch to only keep the config flag for not using
subprojects as the Guix GNOME team is working on moving to glib latest
version
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 8971c11479..ea7b9f1229 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -474,6 +474,7 @@  (define-public gstreamer
     (build-system meson-build-system)
     (arguments
      (list #:disallowed-references (list python)
+     	   #:configure-flags #~(list "--wrap-mode=nofallback")
            #:phases
            #~(modify-phases %standard-phases
                #$@%common-gstreamer-phases
@@ -506,12 +507,12 @@  (define-public gstreamer
      ;;   Requires: glib-2.0, gobject-2.0
      ;;   Requires.private: gmodule-no-export-2.0 libunwind libdw
      (list elfutils                     ;libdw
-           glib libunwind))
+           glib-next libunwind))
     (native-inputs
      (list bash-completion
            bison flex
            gettext-minimal
-           `(,glib "bin")
+           `(,glib-next "bin")
            gobject-introspection
            perl
            pkg-config
@@ -553,7 +554,7 @@  (define-public gst-plugins-base
         "0jcxcx4mgfjvfb3ixibwhx8j330mq3ap469w7hapm6z79q614rgb"))))
     (build-system meson-build-system)
     (propagated-inputs
-     (list glib                     ;required by gstreamer-sdp-1.0.pc
+     (list glib-next                     ;required by gstreamer-sdp-1.0.pc
            gstreamer                ;required by gstreamer-plugins-base-1.0.pc
            libgudev                 ;required by gstreamer-gl-1.0.pc
            ;; wayland-client.h is referred to in
@@ -582,7 +583,7 @@  (define-public gst-plugins-base
            zlib))
     (native-inputs
      (list pkg-config
-           `(,glib "bin")
+           `(,glib-next "bin")
            gobject-introspection
            python-wrapper
            gettext-minimal
@@ -690,7 +691,7 @@  (define libsoup
               (setenv "DBUS_FATAL_WARNINGS" "0"))))))
     (native-inputs
      (list gettext-minimal
-           `(,glib "bin")
+           `(,glib-next "bin")
            gobject-introspection
            gsettings-desktop-schemas
            libxml2
@@ -704,7 +705,7 @@  (define libsoup
            cairo
            flac
            (librsvg-for-system)
-           glib
+           glib-next
            glib-networking
            glu
            gtk+
@@ -827,7 +828,7 @@  (define-public gst-plugins-bad
      (list gstreamer gst-plugins-base))
     (native-inputs
      (list gettext-minimal
-           `(,glib "bin")               ; for glib-mkenums, etc.
+           `(,glib-next "bin")               ; for glib-mkenums, etc.
            gobject-introspection
            gsettings-desktop-schemas
            gst-plugins-good             ;for tests
@@ -845,12 +846,13 @@  (define-public gst-plugins-bad
             ;; ccextractor
             chromaprint
             curl
+            dav1d
             directfb
             ;; dssim
             faad2
             flite
             fluidsynth
-            glib
+            glib-next
             glib-networking
             glu
             gsm
@@ -971,7 +973,7 @@  (define-public gst-plugins-ugly
                    (setenv "DBUS_FATAL_WARNINGS" "0"))))))
     (native-inputs
      (list gettext-minimal
-           `(,glib "bin")
+           `(,glib-next "bin")
            gobject-introspection
            gsettings-desktop-schemas
            perl
@@ -979,7 +981,7 @@  (define-public gst-plugins-ugly
            python-wrapper
            xorg-server-for-tests))
     (inputs
-     (list glib
+     (list glib-next
            glib-networking
            liba52
            libcdio
@@ -1042,11 +1044,11 @@  (define-public gst-editing-services
     (propagated-inputs
      (list gstreamer gst-plugins-base))
     (inputs
-     (list glib glib-networking gtk+ libxml2))
+     (list glib-next glib-networking gtk+ libxml2))
     (native-inputs
      (list flex
            gobject-introspection
-           `(,glib "bin")
+           `(,glib-next "bin")
            gst-plugins-bad
            gst-plugins-good
            perl