diff mbox series

[bug#63184,v2] gnu: Add systemtap

Message ID 20230430225616.27671-1-atai@atai.org
State New
Headers show
Series [bug#63184,v2] gnu: Add systemtap | expand

Commit Message

Andy Tai April 30, 2023, 10:56 p.m. UTC
* gnu/packages/instrumentation.scm (systemtap): New variable
---
 gnu/packages/instrumentation.scm | 38 ++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)


base-commit: 85c137adde84055d78b16d84e5ae4817995bce28
prerequisite-patch-id: f5feb08c9249508d22e0debbe47222324e9f354e
prerequisite-patch-id: de3be9ca0e20edac4bdf93eacda91b65df196c2d
prerequisite-patch-id: 9967fd9b0de5c36d810ca5c346e49762dfd3dad8

Comments

Olivier Dion May 1, 2023, 12:30 a.m. UTC | #1
On Sun, 30 Apr 2023, Andy Tai <atai@atai.org> wrote:
> * gnu/packages/instrumentation.scm (systemtap): New variable
> ---
>  gnu/packages/instrumentation.scm | 38 ++++++++++++++++++++++++++++++++
>  1 file changed, 38 insertions(+)
>
> diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
> index c25086127a..eca7b5bd15 100644
> --- a/gnu/packages/instrumentation.scm
> +++ b/gnu/packages/instrumentation.scm
> @@ -25,6 +26,7 @@ (define-module (gnu packages instrumentation)
>    #:use-module (gnu packages compression)
>    #:use-module (gnu packages datastructures)
>    #:use-module (gnu packages documentation)
> +  #:use-module (gnu packages cpio)
>    #:use-module (gnu packages elf)
>    #:use-module (gnu packages engineering)
>    #:use-module (gnu packages file)

Please keep the #:use-module sorted.  The same applies for define-public.

> +    (synopsis "a GNU/Linux trace/probe tool")

Synopsis start with a capital case I think.  Use `guix lint' to be
sure.
diff mbox series

Patch

diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index c25086127a..eca7b5bd15 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2021, 2022 Olivier Dion <olivier.dion@polymtl.ca>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,6 +26,7 @@  (define-module (gnu packages instrumentation)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages documentation)
+  #:use-module (gnu packages cpio)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages engineering)
   #:use-module (gnu packages file)
@@ -526,3 +528,39 @@  (define-public uftrace
 performance.  It provides the command @command{uftrace}.  User that want to do
 scripting need to install python-3 or luajit in their profile.")
     (license license:gpl2)))
+
+
+(define-public systemtap
+  (package
+    (name "systemtap")
+    (version "4.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://sourceware.org/ftp/systemtap/releases/" name "-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "161smpv4ajqfncmgylvs89bbix1id60nf0g7clmga2lxxax3646h"))))
+    (build-system gnu-build-system)
+    (native-inputs (list cpio python))
+    (inputs (list elfutils))
+
+    (home-page "https://sourceware.org/systemtap/")
+    (synopsis "a GNU/Linux trace/probe tool")
+    (description
+     "SystemTap provides infrastructure to simplify the
+gathering of information about the running Linux system. This assists
+diagnosis of a performance or functional problem. SystemTap eliminates the
+need for the developer to go through the tedious and disruptive
+instrument, recompile, install, and reboot sequence that may be otherwise
+required to collect data.
+
+SystemTap provides a simple command line interface and scripting language for
+writing instrumentation for a live running kernel plus user-space applications.
+We are publishing samples, as well as enlarging the internal \"tapset\" script
+library to aid reuse and abstraction. SystemTap is a tool for complex
+tasks that may require live analysis, programmable on-line response, and
+whole-system symbolic access, and can also handle simple tracing jobs.")
+    (license license:gpl2+)))
+