diff mbox series

[bug#63184] gnu: Add systemtap

Message ID 20230430054102.29098-1-atai@atai.org
State New
Headers show
Series [bug#63184] gnu: Add systemtap | expand

Commit Message

Andy Tai April 30, 2023, 5:41 a.m. UTC
* gnu/packages/debug.scm (systemtap): New variable
---
 gnu/packages/debug.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)


base-commit: 85c137adde84055d78b16d84e5ae4817995bce28
prerequisite-patch-id: f5feb08c9249508d22e0debbe47222324e9f354e
prerequisite-patch-id: de3be9ca0e20edac4bdf93eacda91b65df196c2d
prerequisite-patch-id: 9967fd9b0de5c36d810ca5c346e49762dfd3dad8

Comments

Liliana Marie Prikler April 30, 2023, 6:23 a.m. UTC | #1
Am Samstag, dem 29.04.2023 um 22:41 -0700 schrieb Andy Tai:
> * gnu/packages/debug.scm (systemtap): New variable
> ---
>  gnu/packages/debug.scm | 38 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 38 insertions(+)
> 
> diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
> index fe00cb5705..3e01c7f0a2 100644
> --- a/gnu/packages/debug.scm
> +++ b/gnu/packages/debug.scm
> @@ -48,6 +48,8 @@ (define-module (gnu packages debug)
>    #:use-module (gnu packages check)
>    #:use-module (gnu packages code)
>    #:use-module (gnu packages compression)
> +  #:use-module (gnu packages cpio)
> +  #:use-module (gnu packages elf)
>    #:use-module (gnu packages flex)
>    #:use-module (gnu packages gdb)
>    #:use-module (gnu packages glib)
> @@ -918,3 +920,39 @@ (define-public delve
>      (synopsis "Debugger for the Go programming language")
>      (description "Delve is a debugger for the Go programming
> language.")
>      (license license:expat)))
> +
> +(define-public systemtap
> +  (package
> +    (name "systemtap")
> +    (version "4.9")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> +                    "https://sourceware.org/ftp/systemtap/releases/"
> name "-"
> +                    version ".tar.gz"))
> +              (sha256
> +               (base32
> +               
> "161smpv4ajqfncmgylvs89bbix1id60nf0g7clmga2lxxax3646h"))))
> +    (build-system gnu-build-system)
> +    (native-inputs (list cpio python))
> +    (inputs (list elfutils))
> +
> +    (home-page "https://sourceware.org/systemtap/")
> +    (synopsis "a linux trace/probe tool")
Synopsis should not lead with "a" or "the".
> +    (description
> +     "SystemTap provides free software (GPL) infrastructure to
> simplify the
"free software" is non-informative even with "(GPL)" added, as all
software in Guix should be free.  Leave this information to the license
field.
> +gathering of information about the running Linux system. This
> assists
> +diagnosis of a performance or functional problem. SystemTap
> eliminates the
> +need for the developer to go through the tedious and disruptive
> +instrument, recompile, install, and reboot sequence that may be
> otherwise
> +required to collect data.
> +
> +SystemTap provides a simple command line interface and scripting
> language for
> +writing instrumentation for a live running kernel plus user-space
> applications.
> +We are publishing samples, as well as enlarging the internal
> \"tapset\" script
> +library to aid reuse and abstraction.
> +
> +Among other tracing/probing tools, SystemTap is the tool of choice
> for complex
> +tasks that may require live analysis, programmable on-line response,
> and
> +whole-system symbolic access. SystemTap can also handle simple
> tracing jobs.")
On the whole, this description is very market-y.  I'm sure you can
condense it to a third of its length without losing information. 
(Compression algorithms hate this trick.)

Cheers
Olivier Dion April 30, 2023, 1:56 p.m. UTC | #2
On Sat, 29 Apr 2023, Andy Tai <atai@atai.org> wrote:
> * gnu/packages/debug.scm (systemtap): New variable

I would put this under gnu/packages/instrumentation.scm.
Andy Tai May 11, 2023, 11:40 p.m. UTC | #3
funny issue with Guix QA:

https://qa.guix.gnu.org/issue/63184

shows  13482 packages waiting to build for a package addition patch
for target i586-gnu
That shall make no sense.   The package is Linux kernel specific, as well.
Christopher Baines May 12, 2023, 6:50 a.m. UTC | #4
Andy Tai <atai@atai.org> writes:

> funny issue with Guix QA:
>
> https://qa.guix.gnu.org/issue/63184
>
> shows  13482 packages waiting to build for a package addition patch
> for target i586-gnu
> That shall make no sense.   The package is Linux kernel specific, as well.

This isn't a QA issue, it's an actual issue with the derivations,
they're very broken.

I've got some patches here https://issues.guix.gnu.org/63416

Note that even though this information is showing up, the i586-gnu
system isn't looked at when considering the "status" [2].

2: https://git.cbaines.net/guix/qa-frontpage/tree/guix-qa-frontpage/issue.scm#n50
diff mbox series

Patch

diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index fe00cb5705..3e01c7f0a2 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -48,6 +48,8 @@  (define-module (gnu packages debug)
   #:use-module (gnu packages check)
   #:use-module (gnu packages code)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages cpio)
+  #:use-module (gnu packages elf)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages gdb)
   #:use-module (gnu packages glib)
@@ -918,3 +920,39 @@  (define-public delve
     (synopsis "Debugger for the Go programming language")
     (description "Delve is a debugger for the Go programming language.")
     (license license:expat)))
+
+(define-public systemtap
+  (package
+    (name "systemtap")
+    (version "4.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://sourceware.org/ftp/systemtap/releases/" name "-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "161smpv4ajqfncmgylvs89bbix1id60nf0g7clmga2lxxax3646h"))))
+    (build-system gnu-build-system)
+    (native-inputs (list cpio python))
+    (inputs (list elfutils))
+
+    (home-page "https://sourceware.org/systemtap/")
+    (synopsis "a linux trace/probe tool")
+    (description
+     "SystemTap provides free software (GPL) infrastructure to simplify the
+gathering of information about the running Linux system. This assists
+diagnosis of a performance or functional problem. SystemTap eliminates the
+need for the developer to go through the tedious and disruptive
+instrument, recompile, install, and reboot sequence that may be otherwise
+required to collect data.
+
+SystemTap provides a simple command line interface and scripting language for
+writing instrumentation for a live running kernel plus user-space applications.
+We are publishing samples, as well as enlarging the internal \"tapset\" script
+library to aid reuse and abstraction.
+
+Among other tracing/probing tools, SystemTap is the tool of choice for complex
+tasks that may require live analysis, programmable on-line response, and
+whole-system symbolic access. SystemTap can also handle simple tracing jobs.")
+    (license license:gpl2+)))