diff mbox series

[bug#63179,2/2] gnu: browserpass-native: Use new package style.

Message ID 20230429212811.14469-2-timotej.lazar@araneo.si
State New
Headers show
Series Update browserpass-native | expand

Commit Message

Timotej Lazar April 29, 2023, 9:28 p.m. UTC
* gnu/packages/password-utils.scm (browserpass-native)[arguments]: Use
gexps. Drop trailing #t from phases.
---
 gnu/packages/password-utils.scm | 71 ++++++++++++++-------------------
 1 file changed, 31 insertions(+), 40 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 17427bc07c..0a3f2551c9 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -911,46 +911,37 @@  (define-public browserpass-native
         (base32 "1if72k526sqqxnw250qwxvzwvh1w0k8ag4p4xq3442b22hywx72i"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "github.com/browserpass/browserpass-native"
-       #:install-source? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'patch-makefile
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               ;; This doesn't go in #:make-flags because the Makefile itself
-               ;; gets installed.
-               (substitute*
-                   "src/github.com/browserpass/browserpass-native/Makefile"
-                 (("PREFIX \\?= /usr")
-                  (string-append "PREFIX ?= " out)))
-               #t)))
-         (add-before 'build 'configure
-           (lambda _
-               (with-directory-excursion
-                   "src/github.com/browserpass/browserpass-native"
-                 (invoke "make" "configure"))
-             #t))
-         (replace 'build
-           (lambda _
-               (with-directory-excursion
-                   "src/github.com/browserpass/browserpass-native"
-                 (invoke "make"))
-             #t))
-         (replace 'install
-           (lambda _
-             (with-directory-excursion
-                 "src/github.com/browserpass/browserpass-native"
-               (invoke "make" "install"))
-             #t))
-         (add-after 'install 'wrap-executable
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out"))
-                   (gnupg (assoc-ref inputs "gnupg")))
-               (wrap-program (string-append out "/bin/browserpass")
-                 `("PATH" ":" prefix
-                   (,(string-append gnupg "/bin"))))
-               #t))))))
+     (list #:import-path "github.com/browserpass/browserpass-native"
+           #:install-source? #f
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'build 'patch-makefile
+                 (lambda _
+                   ;; This doesn't go in #:make-flags because the Makefile
+                   ;; itself gets installed.
+                   (substitute* "src/github.com/browserpass/browserpass-native/Makefile"
+                     (("PREFIX \\?= /usr")
+                      (string-append "PREFIX ?= " #$output)))))
+               (add-before 'build 'configure
+                 (lambda _
+                   (with-directory-excursion
+                       "src/github.com/browserpass/browserpass-native"
+                     (invoke "make" "configure"))))
+               (replace 'build
+                 (lambda _
+                   (with-directory-excursion
+                       "src/github.com/browserpass/browserpass-native"
+                     (invoke "make"))))
+               (replace 'install
+                 (lambda _
+                   (with-directory-excursion
+                       "src/github.com/browserpass/browserpass-native"
+                     (invoke "make" "install"))))
+               (add-after 'install 'wrap-executable
+                 (lambda _
+                   (wrap-program (string-append #$output "/bin/browserpass")
+                     `("PATH" ":" prefix
+                       (,(string-append #$(this-package-input "gnupg") "/bin")))))))))
     (native-inputs
      (list which))
     (inputs