diff mbox series

[bug#63165,1/2] gnu: Add python-jaraco-test.

Message ID 20230429053109.163211-1-kiasoc5@disroot.org
State New
Headers show
Series Add python-jaraco-test, update python-cssutils. | expand

Commit Message

kiasoc5 April 29, 2023, 5:31 a.m. UTC
* gnu/packages/python-xyz.scm (python-jaraco-test): New variable.
---
 gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e2d082091f..02bb96111b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9258,6 +9258,37 @@  (define-public python-jaraco-packaging
 releases.")
     (license license:expat)))
 
+(define-public python-jaraco-test
+  (package
+    (name "python-jaraco-test")
+    (version "5.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "jaraco.test" version))
+              (sha256
+               (base32
+                "0h0x8qmvfkfqvwdx2m7kwhn53sg26k8gkaas7s1730ak772zqrvz"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (replace 'check
+                     (lambda _
+                       (invoke "pytest" "-vv" "-k" "http"))))))
+    (propagated-inputs (list python-jaraco-context python-jaraco-functools))
+    (native-inputs (list python-flake8
+                         python-pytest
+                         python-pytest-black
+                         python-pytest-checkdocs
+                         python-pytest-cov
+                         python-pytest-enabler
+                         python-pytest-flake8
+                         python-pytest-mypy))
+    (home-page "https://github.com/jaraco/jaraco.test")
+    (synopsis "Testing support by jaraco")
+    (description "This package provides testing support by jaraco.")
+    (license license:expat)))
+
 (define-public python-simplegeneric
   (package
     (name "python-simplegeneric")