diff mbox series

[bug#63080] gnu: stalonetray: Update to 0.8.5.

Message ID 20230426001152.71300-1-kiasoc5@disroot.org
State New
Headers show
Series [bug#63080] gnu: stalonetray: Update to 0.8.5. | expand

Commit Message

kiasoc5 April 26, 2023, 12:11 a.m. UTC
The last update for stalonetray.scm was in 2016, and it only contains stalonetray. Could it be moved to xdisorg.scm?

*  (stalonetray): Update to 0.8.5.
[source]: Switch to git reference from GitHub.
[arguments](phases): add phase to fix docbook root.
[inputs]: Add libxpm.
[native-inputs]: Add autoconf, autoconf, automake, libxslt, docbook-xsl.
[homepage]: Update.
---
 gnu/packages/stalonetray.scm | 38 +++++++++++++++++++++++++++---------
 1 file changed, 29 insertions(+), 9 deletions(-)


base-commit: 8093c6ba21c51efe901ba98ce698c545bf13dcd0

Comments

Efraim Flashner May 1, 2023, 2:15 p.m. UTC | #1
On Tue, Apr 25, 2023 at 08:11:52PM -0400, kiasoc5 wrote:
> The last update for stalonetray.scm was in 2016, and it only contains stalonetray. Could it be moved to xdisorg.scm?

That's fine with me.
Ludovic Courtès Aug. 15, 2023, 9:23 p.m. UTC | #2
Hi,

kiasoc5 <kiasoc5@disroot.org> skribis:

> The last update for stalonetray.scm was in 2016, and it only contains stalonetray. Could it be moved to xdisorg.scm?
>
> *  (stalonetray): Update to 0.8.5.
> [source]: Switch to git reference from GitHub.
> [arguments](phases): add phase to fix docbook root.
> [inputs]: Add libxpm.
> [native-inputs]: Add autoconf, autoconf, automake, libxslt, docbook-xsl.
> [homepage]: Update.

[...]

> See <https://issues.guix.gnu.org/63080>.
>
> * gnu/packages/stalonetray.scm (stalonetray): Move from here…
> * gnu/packages/xdisorg.scm (stalonetray): …to here.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.

Finally applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/stalonetray.scm b/gnu/packages/stalonetray.scm
index 65732313fe..37b5cdaae3 100644
--- a/gnu/packages/stalonetray.scm
+++ b/gnu/packages/stalonetray.scm
@@ -18,28 +18,48 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages stalonetray)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
-  #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module ((guix licenses) #:select (gpl2+))
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages docbook)
+  #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
 (define-public stalonetray
   (package
     (name "stalonetray")
-    (version "0.8.3")
+    (version "0.8.5")
     (source
      (origin
-       (method url-fetch)
+       (method git-fetch)
        (uri
-        (string-append "mirror://sourceforge/stalonetray/stalonetray/stalonetray-"
-                       version "/stalonetray-" version ".tar.bz2"))
+	(git-reference
+	 (url "https://github.com/kolbusa/stalonetray")
+	 (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "0k7xnpdb6dvx25d67v0crlr32cdnzykdsi9j889njiididc8lm1n"))))
-    (inputs (list libx11))
+	(base32
+	 "074wy1xppfycillbxq6fwrq87ik9glc95083df5vgm20mhzni7pz"))))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+	  (add-after 'unpack 'fix-docbook-root
+	    (lambda _
+	      (substitute* "configure.ac"
+		(("AC_SUBST\\(DOCBOOK_ROOT\\)" all)
+		 (string-append "DOCBOOK_ROOT="
+				#$(this-package-native-input "docbook-xsl")
+				"/xml/xsl/docbook-xsl-"
+				#$(package-version (this-package-native-input "docbook-xsl"))
+				"; " all))))))))
+    (inputs (list libx11 libxpm))
+    (native-inputs (list autoconf automake libxslt docbook-xsl))
     (build-system gnu-build-system)
-    (home-page "https://stalonetray.sourceforge.net")
+    (home-page "https://kolbusa.github.io/stalonetray")
     (synopsis "Standalone freedesktop.org and KDE systray implementation")
     (description
      "Stalonetray is a stand-alone freedesktop.org and KDE system