diff mbox series

[bug#63075,1/2] gnu: Fix supercollider.

Message ID 20230425203559.uzhf3mwdqcc4imvv@blackbox
State New
Headers show
Series [bug#63075,1/2] gnu: Fix supercollider. | expand

Commit Message

Gabriel Wicki April 25, 2023, 8:35 p.m. UTC
From f67786eb958a65ba778f67a8f443fa3d24293438 Mon Sep 17 00:00:00 2001
Message-Id: <f67786eb958a65ba778f67a8f443fa3d24293438.1682453413.git.gabriel@erlikon.ch>
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Tue, 25 Apr 2023 22:03:03 +0200
Subject: [PATCH 1/2] gnu: Fix supercollider.

* gnu/packages/audio.scm (supercollider): Fix the build.
[configure-flags] Re-enable DLIBSCSYNTH.
[phases] New phase fix-struct-SOUNDFILE-tag.
[inputs] Add ruby and python to appease the build process.
---
 gnu/packages/audio.scm | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès April 28, 2023, 6:50 p.m. UTC | #1
Hi,

Gabriel Wicki <gabriel@erlikon.ch> skribis:

>>From f67786eb958a65ba778f67a8f443fa3d24293438 Mon Sep 17 00:00:00 2001
> Message-Id: <f67786eb958a65ba778f67a8f443fa3d24293438.1682453413.git.gabriel@erlikon.ch>
> From: Gabriel Wicki <gabriel@erlikon.ch>
> Date: Tue, 25 Apr 2023 22:03:03 +0200
> Subject: [PATCH 1/2] gnu: Fix supercollider.
>
> * gnu/packages/audio.scm (supercollider): Fix the build.
> [configure-flags] Re-enable DLIBSCSYNTH.
> [phases] New phase fix-struct-SOUNDFILE-tag.
> [inputs] Add ruby and python to appease the build process.

Applied, thanks!

I didn’t apply the ‘guix style’ patch because I’m not sure it brings
much.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index dca5e516a1..109133ba8e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -43,6 +43,7 @@ 
 ;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
 ;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
 ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -119,6 +120,7 @@  (define-module (gnu packages audio)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages rdf)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages ruby)
   #:use-module (gnu packages samba)
   #:use-module (gnu packages sdl)
   #:use-module (gnu packages serialization)
@@ -3485,7 +3487,7 @@  (define-public supercollider
                            "-DSC_QT=ON"
                            "-DCMAKE_BUILD_TYPE=Release"
                            "-DFORTIFY=ON"
-                           ;; "-DLIBSCSYNTH=ON"   ; TODO: Re-enable?
+                           "-DLIBSCSYNTH=ON"
                            "-DSC_EL=OFF") ;scel is packaged individually as emacs-scel
        #:phases
        (modify-phases %standard-phases
@@ -3506,6 +3508,12 @@  (define-public supercollider
                     "SC_Filesystem::instance\\(\\)\\.getDirectory"
                     "\\(DirName::Resource\\) / CLASS_LIB_DIR_NAME"))
                   (string-append "Path(\"" scclass-dir "\")"))))))
+         (add-after 'patch-scclass-dir 'fix-struct-SOUNDFILE-tag
+           (lambda* _
+             (display (getcwd)) (newline)
+             (substitute* "include/plugin_interface/SC_SndBuf.h"
+               (("SNDFILE_tag")
+                "sf_private_tag"))))
          (add-before 'build 'prepare-x
            (lambda _
              (system "Xvfb &")
@@ -3532,6 +3540,8 @@  (define-public supercollider
                   boost
                   boost-sync
                   yaml-cpp
+                  python-wrapper        ;there were warnings in the build process
+                  ruby                  ;there were warnings in the build process
                   qtbase-5
                   qtdeclarative-5
                   qtsvg-5