diff mbox series

[bug#63017,v2,07/24] gnu: Add go-github-com-hashicorp-go-uuid.

Message ID 20230423122748.6770-7-ngraves@ngraves.fr
State New
Headers show
Series [bug#63017,v2,01/24] gnu: Add go-github-com-git-lfs-gitobj-v2. | expand

Commit Message

Nicolas Graves April 23, 2023, 12:27 p.m. UTC
* gnu/packages/golang.scm (go-github-com-hashicorp-go-uuid): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f00c18897e..f11bca3a39 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3840,6 +3840,31 @@  (define-public go-github-com-getsentry-raven-go
 logging system.")
       (license license:bsd-3))))
 
+(define-public go-github-com-hashicorp-go-uuid
+  (package
+    (name "go-github-com-hashicorp-go-uuid")
+    (version "1.0.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hashicorp/go-uuid")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0wd4maaq20alxwcvfhr52rzfnwwpmc2a698ihyr0vfns2sl7gkzk"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/hashicorp/go-uuid"))
+    (home-page "https://github.com/hashicorp/go-uuid")
+    (synopsis "Generate UUID-format strings")
+    (description
+     "This package generates UUID-format strings using high quality bytes.
+It is not intended to be RFC compliant, merely to use a well-understood string
+representation of a 128-bit value.  It can also parse UUID-format strings into
+their component bytes.")
+    (license license:mpl2.0)))
+
 (define-public go-github-com-hashicorp-go-version
   (let ((commit
          "03c5bf6be031b6dd45afec16b1cf94fc8938bc77")