diff mbox series

[bug#63017,v2,05/24] gnu: Add go-github-com-jcmturner-dnsutils-v2.

Message ID 20230423122748.6770-5-ngraves@ngraves.fr
State New
Headers show
Series [bug#63017,v2,01/24] gnu: Add go-github-com-git-lfs-gitobj-v2. | expand

Commit Message

Nicolas Graves April 23, 2023, 12:27 p.m. UTC
* gnu/packages/golang.scm (go-github-com-jcmturner-dnsutils-v2): New variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3b4bd49e8a..4ddd499e43 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1431,6 +1431,33 @@  (define-public go-github-com-jcmturner-aescts-v2
 encryption and decryption methods.")
     (license license:asl2.0)))
 
+(define-public go-github-com-jcmturner-dnsutils-v2
+  (package
+    (name "go-github-com-jcmturner-dnsutils-v2")
+    (version "2.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jcmturner/dnsutils")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "116zbgvfj88vv93fnapmmgyd5g8kzy774cdyzsnnzyzng92j61c9"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/jcmturner/dnsutils/v2"))
+    (propagated-inputs (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/jcmturner/dnsutils")
+    (synopsis "Go library with DNS utils")
+    (description
+     "The dnsutils package provides a Go function to return a map of Service
+Records (SRV) in the order they should be used for a given service, protocol
+and name.  The order is determined by the records' priority and randomized
+selection based on their relative weighting.  This package is useful for
+network applications that require accessing services using SRV records.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-kataras-golog
   (package
     (name "go-github-com-kataras-golog")