diff mbox series

[bug#63017,v2,18/24] gnu: Add go-github-com-olekukonko-ts.

Message ID 20230423122748.6770-18-ngraves@ngraves.fr
State New
Headers show
Series [bug#63017,v2,01/24] gnu: Add go-github-com-git-lfs-gitobj-v2. | expand

Commit Message

Nicolas Graves April 23, 2023, 12:27 p.m. UTC
* gnu/packages/golang.scm (go-github-com-olekukonko-ts): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a985d157bf..ad4ffd9392 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9238,6 +9238,31 @@  (define-public go-github-com-olekukonko-tablewriter
 @end itemize\n")
     (license license:expat)))
 
+(define-public go-github-com-olekukonko-ts
+  (let ((commit "78ecb04241c0121483589a30b0814836a746187d")
+        (revision "0"))
+    (package
+      (name "go-github-com-olekukonko-ts")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/olekukonko/ts")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0k88n5rvs5k5zalbfa7c71jkjb8dhpk83s425z728qn6aq49c978"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/olekukonko/ts"
+         #:tests? #f)) ; inappropriate ioctl for device.
+      (home-page "https://github.com/olekukonko/ts/")
+      (synopsis "Simple Go application to get the size of the terminal")
+      (description "This package provides a simple Go application to get the
+size of the terminal.")
+      (license license:expat))))
+
 (define-public go-github-com-yuin-goldmark
   (package
     (name "go-github-com-yuin-goldmark")