diff mbox series

[bug#63017,v2,16/24] gnu: Add go-github-com-git-lfs-wildmatch-v2.

Message ID 20230423122748.6770-16-ngraves@ngraves.fr
State New
Headers show
Series [bug#63017,v2,01/24] gnu: Add go-github-com-git-lfs-gitobj-v2. | expand

Commit Message

Nicolas Graves April 23, 2023, 12:27 p.m. UTC
* gnu/packages/version-control.scm (go-github-com-git-lfs-wildmatch-v2): New variable.
---
 gnu/packages/version-control.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5f2bc15ae7..4d6c8ecb1e 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2967,6 +2967,29 @@  (define-public go-github-com-git-lfs-pktline
 writing files using the Git pkt-line format used in various Git operations.")
 (license license:expat))))
 
+(define-public go-github-com-git-lfs-wildmatch-v2
+  (package
+    (name "go-github-com-git-lfs-wildmatch-v2")
+    (version "2.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/git-lfs/wildmatch")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0yg6d77d5l6v7cd8vr00y68z9aqb8qs4lidv0hkqh4fvz0ggvpln"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/git-lfs/wildmatch/v2"))
+    (home-page "https://github.com/git-lfs/wildmatch")
+    (synopsis "Go implementation of Git's wildmatch")
+    (description
+     "This package is an implementation of Git's wildmatch.c-style pattern
+matching.")
+    (license license:expat)))
+
 (define-public go-github-com-git-lfs-gitobj-v2
   (package
     (name "go-github-com-git-lfs-gitobj-v2")