diff mbox series

[bug#63017,v2,13/24] gnu: Add go-github-com-dpotapov-go-spnego.

Message ID 20230423122748.6770-13-ngraves@ngraves.fr
State New
Headers show
Series [bug#63017,v2,01/24] gnu: Add go-github-com-git-lfs-gitobj-v2. | expand

Commit Message

Nicolas Graves April 23, 2023, 12:27 p.m. UTC
* gnu/packages/golang.scm (go-github-com-dpotapov-go-spnego): New variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 59e52c5a61..f112adbe14 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1979,6 +1979,34 @@  (define-public go-github-com-operatorfoundation-monolith-go
     (description "Monolith-Go is a Go library for working with byte sequences.")
     (license license:expat)))
 
+(define-public go-github-com-dpotapov-go-spnego
+  (let ((commit "298b63a544303a239753d04314aada5bdbad7e4a")
+        (revision "0"))
+    (package
+      (name "go-github-com-dpotapov-go-spnego")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/dpotapov/go-spnego")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0d3b0kazm0jskfml0pkhjn2v49m8dvqj4zymm49ldgvkhl9hcf6w"))))
+      (build-system go-build-system)
+      (arguments `(#:import-path "github.com/dpotapov/go-spnego"))
+      (propagated-inputs (list go-github-com-stretchr-testify
+                               go-github-com-jcmturner-gokrb5-v8
+                               go-golang-org-x-net))
+      (home-page "https://github.com/dpotapov/go-spnego")
+      (synopsis "Simple golang library for retry mechanism")
+      (description "This package is a simple Go library that provides retry
+functionality for functions that may fail.  It includes various customizable
+retry strategies, such as fixed delay, backoff delay, and random delay.")
+      (license license:expat))))
+
 (define-public go-github-com-deckarep-golang-set
   (package
     (name "go-github-com-deckarep-golang-set")