diff mbox series

[bug#63003,2/3] gnu: Add go-github-com-coreos-go-systemd-activation.

Message ID 20230421195515.10316-2-guix@twilken.net
State New
Headers show
Series gnu: Add restic-rest-server. | expand

Commit Message

Timo Wilken April 21, 2023, 7:55 p.m. UTC
Required by restic-rest-server; see following commit.

* gnu/packages/golang.scm (go-github-com-coreos-go-systemd-activation): New variable.
---
 gnu/packages/golang.scm | 25 ++++++++++++++++++++++++-
 1 file changed, 24 insertions(+), 1 deletion(-)

Comments

Timo Wilken April 21, 2023, 7:59 p.m. UTC | #1
On Fri Apr 21, 2023 at 9:55 PM CEST, Timo Wilken wrote:
> Required by restic-rest-server; see following commit.
>
> * gnu/packages/golang.scm (go-github-com-coreos-go-systemd-activation): New variable.
> 
> @@ -8980,7 +9003,7 @@ (define-public go-github-com-emirpasic-gods
>      (build-system go-build-system)
>      (arguments
>       `(#:import-path "github.com/emirpasic/gods"
> -       ; Source-only package
> +                                        ; Source-only package
>         #:tests? #f
>         #:phases
>         (modify-phases %standard-phases

Oops, sorry about this accidental reformatting! Should I resend this
patch series or can that be removed when applying the commit?
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cca5aacdb6..78864291ae 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8964,6 +8964,29 @@  (define-public go-github-com-coreos-go-semver
 It lets you parse and compare two semantic version strings.")
     (license license:asl2.0)))
 
+(define-public go-github-com-coreos-go-systemd-activation
+  (package
+    (name "go-github-com-coreos-go-systemd-activation")
+    (version "0.0.0-20191104093116-d3cd4ed1dbcf")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/coreos/go-systemd")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "193mgqn7n4gbb8jb5kyn6ml4lbvh4xs55qpjnisaz7j945ik3kd8"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/coreos/go-systemd/activation"
+       #:unpack-path "github.com/coreos/go-systemd"))
+    (home-page "https://github.com/coreos/go-systemd")
+    (synopsis "Go bindings to systemd socket activation")
+    (description "Go bindings to systemd socket activation; for writing and
+using socket activation from Go.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-emirpasic-gods
   (package
     (name "go-github-com-emirpasic-gods")
@@ -8980,7 +9003,7 @@  (define-public go-github-com-emirpasic-gods
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/emirpasic/gods"
-       ; Source-only package
+                                        ; Source-only package
        #:tests? #f
        #:phases
        (modify-phases %standard-phases